poolec

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 38 total)
  • Author
    Posts
  • in reply to: Restricting some categories to Visitors #48472

    poolec
    Member

    Hi,

    Having played around with things I’ve made it work with no CSS required – here’s how.

    Duplicated the map and called labelled it for 2019
    Added three more categories for 2019 sightings and set them to work with the new map
    Changed the old category icons to smaller transparent dots and made them unavailable on the new map (I thought this would mean that the data wasn’t shown as well, but it is).

    Doing this means the old data is visible on the new map having duplicated the map and the new categories are only selectable in the VGM area – which is exactly what I needed.

    The live map ready for users to add their moth and caterpillar sightings can be seen here:

    Box Moth & Caterpillar Tracker

    Kind regards,

    Chris

    • This reply was modified 9 months, 1 week ago by  poolec.
    in reply to: Restricting some categories to Visitors #48330

    poolec
    Member

    Hi Perry,

    I would need help with that as I can muddle by with basic CSS, but not much more!

    For the long term it might be something to add to the categories settings in the back end – a tick box against each category “Selectable in VGM” rather than as at present where all categories are either on or off. Should I post this in the feature request thread?

    Kind regards,

    Chris

    in reply to: Marker list not showing & Processing overlay #47879

    poolec
    Member

    Hi Perry,

    OK, most of that was way to technical for me, but I deactivated the plugins and then reactivated them one by one. It seems to be the Woocommerce plugin that is causing the problem on this installation.

    I created a copy of the live site and upgraded that to the current versions of WP Google Maps and it has worked fine. So there is clearly a corruption of some form on my Dev05 site, so I think it is time to reset it with a copy of the live site after I have noted the config changes I have been testing out.

    Thanks for the pointers,

    Chris

    PS Thought you might like to know that the data collected from the EBTS UK website using WP Google Maps last year is being used as part of a paper to be published tracking the spread of box tree moths across the UK.

    in reply to: Marker list not showing & Processing overlay #47819

    poolec
    Member
    This reply has been marked as private.
    in reply to: HTTP users not seeing map #43162

    poolec
    Member

    Hi,

    Quick update – 1&1 have now fixed the https redirect issue so in theory nobody should ever get to the http version of the page and have this problem, but it would potentially affect others who aren’t using https sites.

    Thanks

    Chris

    in reply to: Update please on 'Near vacinity not working after updates' #42209

    poolec
    Member
    This reply has been marked as private.
    in reply to: Update please on 'Near vacinity not working after updates' #42176

    poolec
    Member

    Hi Perry,

    Still no release of a solution for this – any idea when it will be fixed in the release version so I can give my users the full experience they used to have?

    Thanks

    Chris

    in reply to: Near vacinity not working after updates #41666

    poolec
    Member

    Hi Dylan,

    It’s been nearly 4 weeks and lots of updates but none have fixed the issue with the near vicinity problem or the short codes not working. Please can you give me an update on when they will be released as it is impacting the user experience on the live EBTS UK website now that we have multiple markers at the same point.

    Kind regards,

    Chris

    in reply to: Near vacinity not working after updates #40663

    poolec
    Member

    Hi Dylan,

    Just updated the Dev07 website to the latest version and I don’t know if it is because you have tweaked the code on my site, but I’m getting lots of ‘Rendering custom fields’ before the Map appears. Just thought I’d let you know.

    Kind regards,

    Chris

    in reply to: Near vacinity not working after updates #40555

    poolec
    Member

    Hi Dylan,

    Great I look forward to seeing an update soon and thanks for bearing with me through all the suggestions and observations.

    Keep up the brilliant work,

    Chris

    in reply to: Near vacinity not working after updates #40530

    poolec
    Member

    Hi Dylan,

    Sorry for the delay in replying.

    Good job with the markers which now appear to be working reliably what ever order you select them in or method of selection.

    One the back end editing, just one suggestion. Take a look at the attached screenshot. Is there anyway you can get the width of the edit fields and map to be the same width as the Marker list (which is responsive and fills the available width depending on available screen size)? Not the end of the world if it isn’t possible as what you have implemented allows much easier editing of the fields on a mobile device.

    Assuming that it is possible to make the last tweak, when will the update go live so I can apply it to the live site?

    All the best,

    Chris

    Attachments:
    You must be logged in to view attached files.
    in reply to: Near vacinity not working after updates #40334

    poolec
    Member

    Hi Dylan,

    Nearly there I think – the markers now seem to open ok for however many clicks you make, though on clicking a marker entry in the list it then gets drawn as the centre marker, so you do loose the chronology. Also if you click on an actual marker, other then the one at the centre, the centre one disappears.

    On the tweaks you’ve made to the back end editing display, it’s definitely better, but it is still cutting off the right hand side of the input fields – see attached screen shots one shows the display when portrait where it crops the input fields and the other in landscape where it doesn’t expand to the right which would help.

    Keep up the good work.

    Chris

    Attachments:
    You must be logged in to view attached files.
    in reply to: Near vacinity not working after updates #40284

    poolec
    Member

    Hi Dylan,

    The additional code seems to work for the first time that you click on the entries in the marker list, but when you click on an item for a second time, it collapses all the markers so they are all on top of each other.

    With regard the map, it is in the backend when you are trying to authorise a marker or enter one – see attached screen shot.

    Thanks

    Chris

    Attachments:
    You must be logged in to view attached files.
    in reply to: Near vacinity not working after updates #40244

    poolec
    Member

    Hi Dylan,

    1) Sounds like it’s worth trying and even if not perfect, it needs to show the correct location which it isn’t reliably at the moment.
    2) Understood and I look forward to the trying out the redeveloped system.
    3) As above looking forward to trying the redeveloped system.

    I’m very happy to assist with any testing and providing feedback if you need any help.

    My only other issue with the system as it stands is that when using a mobile phone to authorise a marker the map stops you seeing the full length of the fields, it’s like it is in a column of its own – really difficult. Could the map in mobile versions be either above or below the fields rather than in a column on the right?

    All the best,

    Chris

    in reply to: Near vacinity not working after updates #40179

    poolec
    Member

    Hi Dylan,

    Some is working, but not all.
    1) The zoom level works, but try searching for W4 1BZ and then click on the entries one at a time from top to bottom of the marker list. The first works fine as does the second, but the third and fourth move the focus of the map to the wrong positions in Chrome, Internet Explorer & Edge. On Firefox it works correctly the first time you select any of the items from the marker list, but the second time yo select the 3rd or 4th item in the list it shows the wrong location on the map.
    2) This is linked to the near vicinity radius – if another marker with a different address is found then the line is drawn. Try using my data, set the radius to 50m and enter W4 1BZ in the search and you will see the 4 markers on the map, but also a 5th one up and to the left which has a line and just one marker at the end of it.
    3) Yes, but it doesn’t really work very well, for example if you set near vicinity to 10m then the first and second icons are sat on top of each other – I think the way the lines are displayed needs to be looked at as in reality it doesn’t come out looking like it does in the advertising example.
    4) Agreed this is now working correctly – thanks.

    Thanks for continuing to try and solve this, hopefully with this feedback you will be able to sort out the final issues 🙂

    Thanks,
    Chris

Viewing 15 posts - 1 through 15 (of 38 total)