'You have exceeded your request quota for this API'

New home Forums Basic Version 'You have exceeded your request quota for this API'

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #46346
    robmelisi
    Member

    Hi,

    Im wondering if i can get some help. Since the new payment process with google maps nothing works.

    See attached for error message. I have tried everything:

    – all billing set up correctly
    – API key checked multiple times
    – Contacted google directly they have confirmed the API is being called properly
    – Quotas are all set high on google console

    I’m running out of things to check! Please see attached screenshot for the error message.

    Really need to get this working and then sort out the premium version. But can’t do so until i know it will work again.

    Thanks in advance hope to hear from you soon.

    #46413
    Perry
    Moderator

    Hi Rob

    Thank you for getting in touch, sorry to hear you are experiencing API issues.

    I’m afraid your attachment didn’t come through, could you please upload that to a file or image sharing service and send us the link?

    Assuming everything is correctly set up, it sounds like you might have 3rd party software on the page loading a different key. Can you please try “Prevent other plugins and theme from loading Maps API” in Maps -> Settings?

    Kind regards
    – Perry

    #49432
    MaikeJansen
    Member
    This reply has been marked as private.
    #49454
    Perry
    Moderator

    Hi Maike

    We author a free plugin, which offers you a choice of Google Maps and OpenLayers.

    We also offer a professional add-on, which we charge for, that allows you to use either Google Maps or OpenLayers. We charge a one off fee for this presently.

    Google themselves now charge for use of their mapping API, as of June last year.

    This is Google’s policy decision and as such, this is completely out of our control.

    We still offer a free plugin, but if you wish to use our plugin with Google Maps, you need to set up billing in your Google API console.

    Google offer a substantial amount of free courtesy usage each month, which should be more than enough for most use cases. However they do stipulate that you must set in billing information, even if no money changes hands so to speak.

    Alternatively, you can use OpenLayers, which is completely free.

    I hope that helps?

    Kind regards
    – Perry

    #50401
    mahmoud
    Member

    [wpgmza id="1"]

    #50424
    Perry
    Moderator

    Hi Mahmoud

    How may we help you?

    Kind regards
    – Perry

    #51690
    IvedeLeeuw
    Member
    This reply has been marked as private.
    #51722
    Perry
    Moderator

    Hi Ive

    Thank you for getting in touch.

    You need to set up billing on your Google API Dashboard – Google now bills for use of their JavaScript API.

    The overwhelming majority of users we deal with never exceed the free monthly quota, so it’s unlikely you will be charge unless you’re a heavy use, but you will need to set in billing details.

    Does that help?

    Kind regards
    – Perry

    #51843

    Was there account changes ? My old wpgooglemap account wasn’t working, I was forced to create a new one. Now it says the free plugin is no longer available.

    What should I do ?

    #51862
    Perry
    Moderator

    Hi there

    We apologize for the plugin being removed from the WordPress repository. The plugin team removed the plugin because their emails to us were bouncing. The emails were being sent to an old email address that was not in use anymore. The plugin is now back on the repository and everything should be working as expected. If the plugin was removed by your security plugin, please re-enable the plugin in the Plugins page of your wp-admin section.

    Regarding your account changes, could you please let us know if you are seeing any error messages, or link us to your map page so we may assist?

    Kind regards
    – Perry

    #53717

    I have 6 WordPress sites in my Google API console and all stopped working – shows an error of “You have exceeded your request quota for this API”.

    I checked my Billing and had a cancelled CC for payment – fixed that and checked the console to make sure all 6 were connected to my billing account – yes they are.

    Projects linked to this billing account
    Project name / Project ID

    igHome – ighome-225003

    Fat Duck – fat-duck

    Simply Divine – simply-divine-232219

    IatBBC – iatbbc-1530498495361

    A Room with a View – alert-palace-223922

    WWBBIA – wwbbia-223923

    One of the 6 is http://aroomwithaview.us, another http://innatblackberrycreek.com

    I don’t know what else to check.

    Thanks in advance,

    Michael

    #53719
    Perry
    Moderator

    Hi Michael

    Thank you for getting in touch, sorry to hear you are experiencing issues.

    This error is quite unambiguous, if you are absolutely sure that you have set up billing correctly, with a valid card, then the only other thing this can mean is that you have exceeded your usage quota. Did you check your usage for this key?

    Kind regards
    – Perry

    #56933
    Alfredo
    Member

    I have the same problem with my page. Fails in store locator.

    Conseguí tu copa

    Sorry about my little english, because i am from Argentina.

    #56934
    Alfredo
    Member

    Hello
    Today I paid you $18 for an api code, but it doens t work. So, I bought another api code from google and work perfect.
    Can you cancel my payment?

    Thank you

    #56946
    Perry
    Moderator

    Hi there

    Thank you for getting in touch, sorry to hear you are experiencing issues.

    We took a look at the page you linked us to and the Store Locator appears to be working without issue.

    If you could please contact us on https://www.wpgmaps.com/contact-us to request a refund on your Cloud API key then we can take care of that for you confidentially.

    Kind regards
    – Perry

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.