VGM right click and drag methods not working

New home Forums Visitor Generated Markers VGM right click and drag methods not working

This topic contains 8 replies, has 2 voices, and was last updated by  blackcap 5 months, 2 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #49044

    blackcap
    Member

    Hello,
    The site (https://www.otonabeeward.ca) currently has WP Google Maps v 7.11.16, Pro v 7.11.21 and VGM v 3.0.9 installed. Mapping engine is OpenLayers and OpenStreetMap. After recent updates to WPGM and Pro, I noticed visitors could no longer right click on the map to add a location or drag and drop to add a location to the VGM form (Opera & Chrome browsers). The only method available to is to manually add a valid address which is a problem because addresses aren’t available from the map interface. I’m not seeing any JavaScript errors. Any suggestions?
    pk

    #49058

    Perry
    Moderator

    Hi there

    Thank you for getting in touch, our apologies for any inconvenience caused.

    We have reproduced this issue at our end and are working towards patching that – we should have a patch available within a few hours for this issue, I will update you here as soon as possible on the issue.

    Thank you for your time and patience in this matter.

    Kind regards
    – Perry

    #49062

    Perry
    Moderator

    Hi there

    We have patched this issue in WP Google Maps – Visitor Generated Markers version 3.10,

    Can you please go to your Dashboard, then go to Updates and update the plugin where prompted to do so on that page.

    You can force a check for updates by clicking “Check again” on that page if necessary.

    Please then confirm that solves the problem?

    Kind regards
    – Perry

    #49132

    blackcap
    Member

    Hi Perry,
    Thanks for your quick response. I requested email notifications but I’m not getting them (I checked my spam folder as well). I’ll have to check here more frequently. I ran the most recently updates (today) for WP Google Maps and the Pro Add-on, but I’m not seeing the available update for VGM 3.10. I cleared my cache, and followed your suggestion of clicking Check Again in the Updates page and still nothing. I also reinstalled WP 5.1.1. Still no update showing for VGM 3.10. Is there any point in deactivating and reactivating VGM?
    pk

    #49137

    Perry
    Moderator

    Hi there

    I beg your pardon, could you please try again today?

    Kind regards
    – Perry

    #49149

    blackcap
    Member

    Hi Perry,
    Thanks for this. I tried again this morning and ‘Check Again’ worked. I was able to update VGM. I am able to right click on the map and add GPS coordinates BUT when I do so, it adds an InfoWindow that reads “California”. We’re not in the US or anywhere near CA, but I believe this map was created using the default map which may have had CA as the base. Also, now when I look at the map preview in the dashboard, all of the InfoWindows read “California”. I was able to submit a test map marker – so that appears to be working just fine.
    pk

    #49150

    Perry
    Moderator

    Hi there

    We are aware of the issue with California (the default address) appearing in the infowindows when using XML pull,

    This will not affect the front end – you can switch to DB pull in Maps -> Settings -> Advanced to solve this issue as a workaround.

    We will also look into this on the VGM page, thank you, with a view to patch these issues on Monday.

    Is there anything else we can help you with?

    Kind regards
    – Perry

    #49154

    blackcap
    Member

    Hi Perry,
    Thanks for the tip re: DB pull in the Advanced settings. That addressed the InfoWindow issue in the dashboard map view. Other than the California issue with new VGMs, that does it. Thanks again for your quick response!
    pk

    #49205

    Perry
    Moderator

    Hi there

    My pleasure!

    We’ll be patching this issue for XML marker pull today.

    Is there anything else I can help you with?

    Kind regards
    – Perry

    #49206

    Perry
    Moderator
Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.