Using Ctrl key to zoom

New home Forums Pro Add-on Using Ctrl key to zoom

This topic contains 8 replies, has 5 voices, and was last updated by  bennetcole 1 month, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #37046

    chgeorge
    Member

    Hi, since the search tool of the forums doesn’t work, I want to ask how to activate the Ctrl+scroll button to zoom in/out, rather than using only the scroll button of the mouse. I use the Pro addon. Thanks!

    #37062

    SupportTeam
    Moderator

    Hi there,

    Thank you for getting in touch with us.

    Can you please enable “Disable Two-Finger Pan” option under Maps → Settings to see if this helps with CTRL + scroll? Can you also send me the URL to your site so I’ll take a look at this?

    Thank you for your time in this.

    Best regards,
    Jarek

    #37063

    chgeorge
    Member

    Yeap, that worked! Thank you!

    #37070

    SupportTeam
    Moderator

    Hi there,

    I’m glad to hear that. Feel free to reach out if you need anything.

    Best

    #44072

    chgeorge
    Member

    I’ve got the latest updates and the problem reappeared, even though I have disabled the ‘Two finger pan’ option…

    #44074

    Steven
    Moderator

    Hi there,

    Thank you so much for getting back to us.

    Could I kindly ask you to provide us with a link to your site so that we may debug this issue further?

    I look forward to hearing back from you.

    Kindest Regards,
    Steven De Beer

    #44111

    uundh
    Member

    I also have that problem. I can disable the mousewheel zoom, but then ctrl+mousewheel only zooms the total page. Expected behavior would be the notice on the map to use ctrl + mousewheel to zoom.
    Like here: https://developers.google.com/maps/documentation/javascript/adding-a-google-map

    #44116

    Steven
    Moderator

    Hi there,

    Thank you so much for getting in touch, and my sincerest apologies for any inconvenience.

    Could I kindly ask you to supply us with a link to your website so that we may take a closer look?

    I look forward to helping debug this issue further.

    Kindest Regards,
    Steven De Beer

    #55233

    bennetcole
    Member

    You can use setOnCameraChangeListener. When you stop zooming, you reset the center of the map

            map.setOnCameraChangeListener(new OnCameraChangeListener(){
    
                @Override
                public void onCameraChange(CameraPosition cp) {
                    map.animateCamera(CameraUpdateFactory.newLatLngZoom(point,cp.zoom));
    
                }});

    Try it to disable the scrolling : map.getUiSettings().setScrollGesturesEnabled(false); This should disable scrolling without disturb the zooming

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.