Using 2 maps with different settings for each map.

New home Forums Pro Add-on Troubleshooting Using 2 maps with different settings for each map.

This topic contains 6 replies, has 2 voices, and was last updated by  mediagrant 4 months, 4 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #50829

    mediagrant
    Member

    Good morning, I have a website that uses 2 separate maps (maybe more in time) [wpgmza id="1"] and [wpgmza id="2"].
    I require different settings in the layout for these maps, I have the following settings in the advanced section: –
    .wpgmza_map{
    float:left !important;
    width: 70% !important;
    }

    .wpgmza_map+ div {
    clear:right !important;
    float:left !important;
    width:30% !important;
    padding: 10px;
    }

    .dataTables_length {
    display: none;
    }
    .dataTables_paginate{
    display: none;
    }
    .dataTables_info{
    display: none;
    }
    .addressInput, .wpgmza_sl_radius_select {
    width: 20% !important;
    }
    .wpgmza_sl_radius_div,
    .wpgmza_sl_radius_select {
    display: none;
    }
    .wpgmza_sl_query_div {
    display: inline;
    However I only wnt these setting to appear in map one and not map 2.
    How can i do this please?

    Thanks kindly.
    Mediagrant

    #50833

    Steven
    Moderator

    Hi there,

    Thank you so much for getting in touch, we really appreciate your time.

    You should be able to use an attribute selector such as below:
    [data-map-id=123]

    In order to specifically target individual maps and apply the custom CSS appropriately.

    For example:

    .wpgmza_map[data-map-id=1]{
    float:left !important;
    width: 70% !important;
    }

    This should target Map ID 1 and not affect your secondary map with the ID of 2.

    Please let me know if this helps?

    Kindest Regards,
    Steven De Beer

    #50887

    mediagrant
    Member

    Thank you Steven for getting back to me so quickly, I will complete these changes over the weekend and get back to you as soon as I can.
    Mediagrant

    #50893

    Steven
    Moderator

    Hi there,

    Thank you so much for getting back to me.

    Not a problem at all.

    Have a great weekend ahead.

    Kindest Regards,
    Steven De Beer

    #51315

    mediagrant
    Member

    Hi Steven,
    This hasn’t worked for me. 🙁
    Is there another option please?

    #51318

    Steven
    Moderator

    Hi again,

    Thank you so much for getting back to us.

    If you are open to perhaps creating a temporary admin account for us to log in to, one of our agents should be able to log in and apply this CSS for you and ensure that this works correctly.

    If you are interested in this, could I kindly suggest opening a ticket here: https://www.wpgmaps.com/contact-us/

    We look forward to hearing back from you.

    Kindest Regards,
    Steven De Beer

    #51392

    mediagrant
    Member

    Hi Guys,
    Thank you for your time on this.
    I have resolved the issue by using [data-map-id=”1″] this works perfectly for me the original one you sent through didnt have the “”.
    This ticket can be cloesed now.
    Thank you for your super support.
    Im am sure I will have more questions later
    Regards
    Grant

    #51397

    Steven
    Moderator

    Hi Grant,

    Thank you so much for getting back to us.

    My sincerest apologies for that, it appears our support desk seems to strip out the quotation marks.

    I am glad this is now working, however, and please do let us know if you have any other questions or issues as we are always eager to assist. 🙂

    Have a great week further!

    Kindest Regards,
    Steven De Beer

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.