Updated plugin, now clicking a marker immediately loads the marker link

New home Forums Gold Add-on Updated plugin, now clicking a marker immediately loads the marker link

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #68063
    drench
    Participant

    I tried searching but couldn’t find anything similar

    Yesterday I updated the main plugin, along with the Pro and Gold addons. Now clicking a marker immediately loads the marker’s Link URL. You can see the contents of the infowindow briefly but the linked URL immediately loads.

    Any ideas what’s going on and how to stop this? Thanks!

    This is the JS error in the console:

    
    Uncaught TypeError: Cannot read property 'getNorthEast' of undefined
        at WPGMZA.GoogleProMap.WPGMZA.GoogleMap.getBounds (wp-google-maps-pro.min.js?ver=8.1.11+pro-8.1.10:1)
        at WPGMZA.MarkerClusterer.createClusters (wp-google-maps-gold.min.js?ver=5.1.6:1)
        at WPGMZA.MarkerClusterer.setReady (wp-google-maps-gold.min.js?ver=5.1.6:1)
        at WPGMZA.MarkerClusterer.redraw (wp-google-maps-gold.min.js?ver=5.1.6:1)
        at WPGMZA.MarkerClusterer.addMarkers (wp-google-maps-gold.min.js?ver=5.1.6:1)
        at WPGMZA.GoogleProMap.WPGMZA.ProMap.onMarkersPlaced (wp-google-maps-pro.min.js?ver=8.1.11+pro-8.1.10:1)
        at WPGMZA.GoogleProMap.onMarkersPlaced (wp-google-maps-pro.min.js?ver=8.1.11+pro-8.1.10:1)
        at WPGMZA.GoogleProMap._onMarkersPlaced (wp-google-maps-pro.min.js?ver=8.1.11+pro-8.1.10:1)
        at WPGMZA.GoogleProMap.WPGMZA.EventDispatcher._triggerListeners (wp-google-maps-pro.min.js?ver=8.1.11+pro-8.1.10:1)
        at WPGMZA.GoogleProMap.WPGMZA.EventDispatcher.dispatchEvent (wp-google-maps-pro.min.js?ver=8.1.11+pro-8.1.10:1)
    
    • This topic was modified 1 month, 1 week ago by drench.
    • This topic was modified 1 month, 1 week ago by drench.
    #68073
    Matthew
    Moderator

    Hi there,

    Thank you for getting in touch with us, and my apologies for the inconvenience you are experiencing.

    It appears that the “Click marker opens link” setting may have been enabled during your update as this setting implements the exact functionality that you have mentioned. This setting can be found in the “Advanced Settings” tab of your Map Editor (Maps -> Maps -> Edit -> Advanced Settings).

    Thus please could I kindly ask if you may confirm if this setting is currently enabled and if so, please may you disable it?

    I look forward to hearing back from you.

    Kindest Regards,
    Matthew

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.