After update: Issue with JS

New home Forums Pro Add-on After update: Issue with JS

Viewing 15 posts - 1 through 15 (of 36 total)
  • Author
    Posts
  • #43774
    hgg
    Member

    Hi,
    after updating to version 7.10.36 (WP google maps pro) we get the following error (developer console):

    Uncaught TypeError: Cannot read property ‘__’ of undefined
    at wp-google-maps-pro.min.js?ver=7.10.38+pro-7.10.36:1
    wp-google-maps-pro.min.js?ver=7.10.38+pro-7.10.36:1 Uncaught TypeError: WPGMZA.Map.getConstructor(…) is not a constructor
    at Function.WPGMZA.Map.createInstance (wp-google-maps-pro.min.js?ver=7.10.38+pro-7.10.36:1)
    at Object.MYMAP.(/wo-finde-ich-was/anonymous function).init (https://….de/wp-content/plugins/wp-google-maps-pro//js/core.js?ver=7.10.36p:1462:25)
    at InitMap (core.js?ver=7.10.36p:197)
    at HTMLDocument.<anonymous> (core.js?ver=7.10.36p:1270)
    at i (jquery.js?ver=1.12.4:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
    at Function.ready (jquery.js?ver=1.12.4:2)
    at HTMLDocument.K (jquery.js?ver=1.12.4:2)

    Best Regards,
    Hans-Gerd

    • This topic was modified 1 year, 3 months ago by hgg.
    • This topic was modified 11 months, 2 weeks ago by Perry.
    #43778
    hgg
    Member
    This reply has been marked as private.
    #43789
    Perry
    Moderator

    Hi Hans

    The new plugin integrates with the (soon to be built in) Gutenberg editor.

    Can you please confirm which version of WordPress you are running, as the required packages have been bundled since April, if you are up to date you shouldn’t be seeing this error.

    Kind regards
    – Perry

    #43799
    hgg
    Member

    Hi Perry,
    thanks for quick answer.
    WordPress 4.9.8 is running on the website in question.

    Best Regards,
    Hans-Gerd

    #43804
    Perry
    Moderator

    Hi there

    Please update the plugin and Pro add-on, we’ve literally just now released patches for this issue.

    My sincere apologies for any inconvenience caused.

    You can use Dashboard -> Updates -> Check again to force an update check.

    Please let us know if that solves the issue?

    Kind regards
    – Perry

    #43834
    hgg
    Member

    Hi Perry,
    thanks a lot – it works.
    I just saw that the problem could be connected to this:

    Fixed JS error when Gutenberg framework not loaded

    Do you have any idea how to make sure that the Gutenberg framework is loaded? – I think that could be problematic in the future, isn’t it ?

    In addition, the following warning appears in the developer tools:

    wp-google-maps-pro.combined.js:408 Minified script is out of date, using combined script instead.

    This message does not appear in our development environment

    Best Regards,
    Hans-Gerd

    #43884
    Perry
    Moderator

    Hi Hans

    We’ve added code to not load our Gutenberg integration modules when the Gutenberg editor is not present, which solves this issue.

    Gutenberg will not be present if you haven’t installed the Gutenberg plugin.

    Gutenberg will be built into WordPress as of WordPress version 5.0.

    You can disregard the warning about the combined file for the time being, that has very superficial bandwidth implications but nothing you need to worry about. This will be resolved in the next version.

    I hope that helps!

    Kind regards
    – Perry

    #43916
    hgg
    Member

    Hi Perry,
    thanks a lot for quick solving this issue.

    I know that Gutenberg will be standard in November with version 5.0 and we are also preparing for it. At the moment, however, we have activated the Gutenberg plugin only on a development environment.
    We have already checked it out, Gutenberg is not uninteresting, apart from the fact that you won’t get on without Gutenberg in the long run.

    Perfect that the warning will be solved in next version.

    Best Regards,
    Hans-Gerd

    #44648
    hgg
    Member
    This reply has been marked as private.
    #44664
    Perry
    Moderator

    Hi Hans

    You definitely shouldn’t be running a site with developer mode switched on, staging or otherwise, that setting is intended for staff only use.

    Can you please disable that setting and then get back to me so I can see why the map isn’t appearing,

    Can I please also ask that you apply the latest updates as we’ve patched issues relating to this over the last week.

    Kind regards
    – Perry

    #44775
    hgg
    Member

    Hi Perry,
    sorry for the delay, I didn’t receive your answer as mail and only saw it now.

    Of course only our development environment runs in debugging mode. I just tested it and the notice doesn’t appear anymore.

    Thanks

    Best Regards,
    Hans-Gerd

    #44797
    Perry
    Moderator

    Hi Hans

    Sounds like the issue is resolved!

    If I’ve misunderstood and that isn’t the case, please let me know and we’ll investigate further.

    Kind regards
    – Perry

    #44871
    hgg
    Member

    Hi Perry,
    is there a recommendation which JS files should not be minified (i.e. excluded) by WP Rocket ?

    Thanks

    Best Regards,
    Hans-Gerd

    #44873
    hgg
    Member
    This reply has been marked as private.
    #44925
    Perry
    Moderator

    Hi Hans

    Thank you for letting us know on this,

    This issue has been widely reported and we are actively looking into patching this, we should have a fix going out this morning.

    Please bear with us on that and thank you again for reporting, we appreciate it!

    Kind regards
    – Perry

Viewing 15 posts - 1 through 15 (of 36 total)
  • You must be logged in to reply to this topic.