Uncaught Error GoogleProDrawingManager in Backend after Update

New home Forums Basic Version Troubleshooting Uncaught Error GoogleProDrawingManager in Backend after Update

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #66725
    deku86
    Participant

    Hey Guys!
    Thanks for the great plugin, it works really well. Unfortunately i get an error in the backend if i go to the “edit map” page. I can’t edit any markers or settings on the page anymore. The error “Uncaught Error: Object must be an instance of GoogleProDrawingManager (did you call a constructor directly, rather than createInstance?)” occurs in the console. I have the basic version Version 8.1.2, the pro add-on 8.1.1 and the gold add-on 5.1.0 installed. WordPress is up to date too.

    Do you have any ideas how to solve that error?

    Thank you very much!

    Greetings,
    Denny

    #66731
    Steven
    Moderator

    Hi there,

    Thank you so much for getting in touch, we really appreciate your time.

    Could I kindly ask you to navigate to -> Maps -> Settings -> Advanced -> Please enable developer mode towards the bottom and click save.

    Once done, please then disable developer mode and save once more. This will allow some of the scripts to recompile.

    Please then navigate back to the editor and do a hard Refresh and confirm if this helps?

    Failing this, could I kindly ask you to please get in touch via our support desk so that we might take a closer look?
    – https://www.wpgmaps.com/contact-us/

    Kindest Regards,
    Steven De Beer

    #66831
    deku86
    Participant

    Hello Steven,
    thank you very much for your response! The recompiling was helping, and the backend is running again as expected. Only the marker icons are really big after the update (150px) but are set under settings as 30px width/height. It seems like that the setting is ignored. Do you have any ideas how to solve that? I tried to save the settings again, but that was not helping. Is 150px the default value?

    Thanks for your help!

    Greetings,
    Denny

    #66833
    Steven
    Moderator

    Hi Denny,

    Thank you so much for getting back to me.

    Could I kindy ask you to ensure that the Retina setting is enabled for your markers via the marker editor?

    This settings is what tells the plugin to make use of the set icon width and height via the global settings.

    It could be possible that these may have been unchecked at some point?

    Additionally, we did release a few updates which if possible, could I kindly ask you to update to?
    WP Google Maps V8.1.3
    WP Google Maps Pro V8.1.2

    I look forward to hearing back from you.

    Kindest Regards,
    Steven De Beer

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.