Standard markers instead of customer markers

New home Forums Pro Add-on Standard markers instead of customer markers

Viewing 15 posts - 16 through 30 (of 34 total)
  • Author
    Posts
  • #39027
    hgg
    Member
    This reply has been marked as private.
    #39045
    Perry
    Moderator

    Hi Hans

    Please edit the file /wp-content/plugins/wp-google-maps-pro/js/v8/open-layers/ol-pro-marker.js

    Immediately after this:

    var icon = this.getIcon();

    Please add this:

    if("url" in icon)
    icon = icon.url;

    This solves the problem and has been patched into our master code – however we don’t generally put releases out on a Friday afternoon as everybody is out of the office over the weekend.

    Please turn off developer mode in Maps -> Settings -> Advanced after you’ve made this change.

    You will see a warning in the console stating that the minified file is out of date – this will be fixed when the patch gets rolled out.

    Does that solve the problem for you?

    Kind regards
    – Perry

    #39049
    hgg
    Member

    Hi Perry,
    thanks, this solved the problem.

    But there is unfortunately another issue, which I have already described before: When selecting a category, clicking on a marker does not open the info window.

    And it seems that changed settings of the width and height of the markers are not accepted (Retina Icon Width and Height).

    Sorry.

    Best regards,
    Hans-Gerd

    • This reply was modified 1 year, 7 months ago by hgg.
    #39053
    hgg
    Member

    Hi Perry,
    I am surprised: now it works all at once (but I had already deleted the browser cache before)

    But there is unfortunately another issue, which I have already described before: When selecting a category, clicking on a marker does not open the info window.

    By the way: The solution via open layers is a real alternative to google maps. Great job

    Best regards,
    Hans-Gerd

    • This reply was modified 1 year, 7 months ago by hgg.
    #39156
    hgg
    Member
    This reply has been marked as private.
    #39231
    hgg
    Member
    This reply has been marked as private.
    #39412
    hgg
    Member
    This reply has been marked as private.
    #39426
    Perry
    Moderator

    Hi Hans

    I see, my apologies for overlooking this, "Retina Ready" markers are not supported in OpenLayers at the moment.

    You could try using max-width: none; width: 8px !important; height: 8px !important;

    I’m not sure I follow what your end goal is here, could you please clarify?

    Kind regards
    – Perry

    #39432
    hgg
    Member

    Hi Perry,
    I had only noticed this issue during testing and wanted to report it. If we had used open layers, I would have written this in the style.css of our childtheme.
    I will change this website back to google maps now.
    Have a nice weekend

    Best regards,
    Hans-Gerd

    #39445
    Perry
    Moderator

    Hi Hans

    That’s great, I’m glad that’s solved 🙂

    If you would be kind enough to leave me a review at https://wordpress.org/support/plugin/wp-google-maps/reviews/ I’d be very grateful!

    All the best with this project, if you need anything else please don’t hesitate to get in touch!

    Kind regards
    – Perry

    #39453
    hgg
    Member

    Hi Perry,
    I have already given a review, please have a look here 🙂
    https://wordpress.org/support/topic/great-plugin-and-excellent-support-115/

    Kind regards,
    Hans-Gerd

    #39613
    hgg
    Member
    This reply has been marked as private.
    #39680
    Perry
    Moderator

    Hi Hans

    Thank you for reporting this, this is a common issue that’s come up in the last couple of days, we’ll be releasing a patch for this first thing tomorrow, I’m not sure at this stage why the problem has re-emerged but we will be fixing this as soon as possible.

    Please bear with us on this issue, thank you for your patience.

    Kind regards
    – Perry

    #39683
    hgg
    Member

    Hi Perry,
    thanks for answer.

    Please bear with us on this issue, thank you for your patience.

    no problem, I will wait.

    Best regards,
    Hans-Gerd

    #39752
    Perry
    Moderator

    Hi Hans

    I’m pleased to tell you I’ve found the problem are we are releasing a patch as a matter of urgency,

    If you’d like us to fix this on your site ahead of releasing the patch, please provide FTP details to the site and I’ll carry that out for you.

    I’ll leave this ticket open and update you as soon as possible.

    Kind regards
    – Perry

Viewing 15 posts - 16 through 30 (of 34 total)
  • You must be logged in to reply to this topic.