Slow loading images infowindow + VGM uploaded images not visible media library

New home Forums Visitor Generated Markers Troubleshooting Slow loading images infowindow + VGM uploaded images not visible media library

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #69163
    DroneIcoon
    Participant

    Hello,

    I use the WP Google Maps PRO plugin and when I upload a lot markers with image, the images load very slow. I try to solve this by comprimize the images with Smush, but the images uploaded by visitors (VGM) aren’t vissible in the Gallery, so I can’t use Smash for these images.

    The VGM are uploaded to “uploads/2021/05/” but I can’t use smush for this map (is locked). Is there a way to make the VGM visible in the Media Library, so I can use smuch? Or do you have another possibility to make the images load faster?

    When the images aren’t vissible in the library, I can’t do so much to solve the problem.

    Thanks a lot in advance.

    #69168
    DroneIcoon
    Participant

    In addition of above (I just found out):

    When I upload a picture with your plugin to the media Library (or upload a photo myself in the library), the uploaded pictures are scaled to a smaller size (2048 px, 450 KB). When a visitor uploads an photo (VGM), this photo is uploaded in full size (like 4000px, 4 MB). I think this will be the reason why the pictures load very slow (but I couldn’t see this before, because the VGM-pictures aren’t vissible in the library).

    Is it possible to upload the pictures to the Media library when a visitor uploads a picture (VGM) on the same way as I upload a picture to a marker with your plugin (so the pictues will be scaled and smaller).

    Hope you can help me fix this problem.

    #69172
    Steven
    Moderator

    Hi there,

    Thank you so much for getting in touch, we really appreciate your time.

    Unfortunately, VGM cannot make use of the WordPress media library that is used in the backend, simply due to security reasons as that media library would open up vulnerabilities on the frontend. This system is only intended to be used in the admin area.

    This means that VGM can only make use the general media uploader on the frontend. We are going to be looking at improving this system in VGM 4.0, however, might I kindly suggest perhaps limiting your file upload size via wp-config/php.ini files?

    Kindest Regards,
    Steven De Beer

    #69263
    DroneIcoon
    Participant

    Thanks Steven,

    I wil take a look at limiting the image size. In addition a small question:

    I’ve got a semi transparant infowindow. Now I see that the images in the infowindow are also semi transparant, so they are less good visible. Is it possible to undo the transparacy for the images on the infowindow? Or when this isn’t possible I want to undo the transparacy of the whole infowindow. When I change the opacity to 1.00 or remove the line “opacity” in the code below, nothing happens. How can I solve this? The best would be if only the pictures are not transparant. Thanks in advance.

    .wpgmza-infowindow {
    background-color: #2A3744;
    color: #fff;
    padding: 25px;
    opacity: 0.85
    }

    #69265
    Steven
    Moderator

    Hi again,

    Thank you so much for getting back to me.

    Might I kindly ask you to perhaps provide me with a link to your map page?

    This should allow me to take a more direct look at the CSS styles required.

    I look forward to hearing back from you.

    Kindest Regards,
    Steven De Beer

    #69269
    DroneIcoon
    Participant

    Hi Steven,

    This is the site:
    droneplaatsen.nl/

    Full CSS I use:

    *************************************

    .wpgmza-infowindow {
    background-color: #2A3744;
    color: #fff;
    padding: 25px;
    opacity: 0.85
    }

    .ol-info-window-close{
    color: #fff;
    position: relative;
    top: -10px;
    left: 10px;
    }

    .wpgmza_infowindow_description > p{
    margin-bottom: 0 !important;
    }

    .wpgmza_map ~ h2 {
    margin-top: 0;
    font-family: Arial !important;
    text-transform: uppercase !important;
    }

    .wpgmza_map ~ h2 {
    font-weight: bold !important;
    }

    .wpgmza_map {
    height: 800px !important;
    }

    .wpgmza_table tbody {
    color: black;
    }

    /* Changes the font-family */
    .elementor-shortcode {
    font-family: serif !important;
    }

    /* Adds margin to bottom of magin */
    .wpgmza_map {
    margin-bottom: 25px;
    }

    /* changes some elements of form background */
    .wpgmaps_user_form {
    background: #FFFFFF;
    }
    tbody tr:nth-child(odd) {
    background: #b0bec5;
    }

    .wpgmza_infowindow_image {
    max-width: 300px !important;
    max-height: 225px !important;
    }

    ************************

    • This reply was modified 2 years, 10 months ago by DroneIcoon.
    #69283
    Steven
    Moderator

    Hi there,

    Thank you so much for getting back to me.

    Might I suggest changing the following:

    .wpgmza-infowindow {
    background-color: #2A3744;
    color: #fff;
    padding: 25px;
    opacity: 0.85
    }

    To the below:

    .wpgmza-infowindow {
    color: #fff;
    padding: 25px;
    background-color: rgb(42 55 68 / 90%);
    }

    Instead of setting an opacity, simply adjust the background color to include an opacity.

    This should then stop the image from also being transparent.

    Please let me know if this helps?

    Kindest Regards,
    Steven De Beer

    #69305
    DroneIcoon
    Participant

    Hi Steven,

    Thanks again for your response. I changed the code but the images stay transparant (it looks like nothing changes). I already deleted the cache, that didn’t help unfortunately.

    Greetings,

    Pieter

    #69315
    Steven
    Moderator

    Hi Pieter,

    Thank you so much for getting back to me.

    Might I kindly ask if you would perhaps be open to providing temporary login details in a private response to this thread?

    This should allow me to take a closer look to ensure these styles are applied?

    I look forward to hearing back from you.

    Kindest Regards,
    Steven De Beer

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.