Scaling the map does not work

New home Forums Pro Add-on Troubleshooting Scaling the map does not work

Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #42182
    krassavchik
    Member

    After the update, again the map began to approach the mouse wheel … How to fix it?

    Not very convenient when the map is approached by the mouse wheel without pressing the CTRL key

    url: https://www.ulovanet.ru/karta-rybolovnyx-mest-respubliki-tatarstan/#a2

    #42190
    Perry
    Moderator

    Hi there

    Nice to hear from you again, I’m sorry it’s in these circumstances.

    Unfortunately there isn’t any documented way to control this setting. It appears Google are making some changes in this area.

    We’ve tried following their documentation to force this programatically, but the instructions they’ve given are either out of date, or there is a problem at their end with this feature at the moment.

    This is supposed to be controlled with the gestureHandling option, but no matter what you set this value to, and what API version is used, it doesn’t seem like you can toggle this setting.

    I will take another look at their documentation and spend some time running tests this morning, but please be advised we’ve been doing that for the last couple of months now with no change.

    You could disable mousewheel scrolling all together as a workaround?

    Kind regards
    – Perry

    #42244
    krassavchik
    Member

    You did not understand me. So I myself could do …
    The mouse wheel should only work with the CTRL key pressed

    I need the mouse to work, but only when I press CTRL

    Everything was fine, until the last update 2 days ago

    #42248
    Perry
    Moderator

    Hi,

    If I understand correctly, you would like mousewheel to be disable unless the user holds Ctrl.

    Unfortunately, it appears Google are either dropping, making some changes to, testing, or debugging this feature. It appears to work on some pages but not others. I’m afraid you would have to ask Google themselves about this, as it’s a feature of their API and not our plugin.

    We’ve been asked about this quite a few times now, and I have personally reached out to the developers on Google Groups about this, but as of yet I haven’t had a concrete answer, or been able to find any literature on the subject.

    Please see Google’s documentation on Cooperative gesture handling. At the time of writing, I see the “Hold CTRL” overlay when I scroll on this page.

    Their documentation instructs you to pass this option:

    gestureHandling: 'cooperative'

    To enable cooperative gesture handling.

    If you go to your page and enter this into your JavaScript console:

    WPGMZA.maps[0].googleMap.setOptions({gestureHandling: "cooperative"});

    This will set the gestureHandling option to cooperative for your map.

    I did this just now, and it has no effect. You can even put that code in a 1 millisecond loop and it has no effect, and no other software is setting this option. If you want me to look further into this, please enable Developer Mode in Maps -> Settings -> Advanced and I can try forcing that setting at load time, however I’m doubtful this would work considering that’s what the “Two finger pan” setting does, and we’ve observed the same issue with that feature.

    To put it simply, Google’s documentation shows how to enable this feature. We have followed Google’s documentation. The feature does not work.

    Unfortunately there is no way for us to hack or workaround Google’s code. They document one, and only one way to enable this feature. If the feature doesn’t work, there are no other documented ways to enable that feature.

    I’m really sorry we can’t be more forthcoming on this and I genuinely, really dislike to seem like we’re passing the blame on to them, so I hope you appreciate our findings here.

    We will keep you posted on this issue if there are any developments.

    I hope that helps?

    Kind regards
    – Perry

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.