Pro 6.18 clobbers WPDataTables header formatting

New home Forums Gold Add-on Troubleshooting Pro 6.18 clobbers WPDataTables header formatting

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #32395
    tcghs
    Member

    Pro 6.18 is destroying the formatting of the header row created by WPDataTables plugin.

    As an example, see

    Tazewell County Pioneer Certificates

    I have attached screenshots of the headings of the Recognized Prairie Pioneers table on this page before & after WP Google Maps Pro 6.18

    You should easily see how WP Google Maps has destroyed the formatting of the header row.

    I originally reported as a problem to WPDataTables – they responded it was caused by your plugin – showing that the problem disappeared when the Google Maps Pro plugin was deactivated.

    This problem occurs with ANY WPDataTables – not just the Prairie Pioneer one.

    Thanks,
    Mike

    Attachments:
    You must be logged in to view attached files.
    #32398

    Hi Mike,

    Thanks for getting in touch with us.

    Could I please ask you to add the following CSS to ‘Maps’ -> ‘Settings’ -> ‘Advanced’ -> ‘Custom CSS’ or your themes additional CSS:
    .wdtheader {
    color: #fff !important;
    background: #9C0621 !important;
    }

    After saving the settings, please test it again and let me know if it helps.

    Thanks.

    Kind regards,
    Dylan

    #33722
    tcghs
    Member

    Dylan,

    I’m very sorry I haven’t responded earlier – somehow I missed your response.

    Added the above CSS in Maps advanced setting – didn’t make any difference.

    However, putting the CSS in the theme’s custom CSS did change the headings back – but looking closer, I notice besides the headings I had also lost the table borders as well and the column borders.

    I assume this gives you an idea where your plugin has issues?

    Mike

    #33735

    Hi Mike,

    Sorry for the delay in response over the weekend.

    To fix the borders, please add the following CSS:

    .wpDataTable {
    border: 2px solid #9c0621;
    }

    Please let me know if this helps.

    Kind regards,
    Dylan

    #33756
    tcghs
    Member

    Hi, Dylan,

    Border color was wrong for the table body – tweaked it a bit – what I have to this point is

    .wdtheader {
    color: #f5f5dc !important;
    background: #9C0621 !important;
    border:2px solid #9c0621;
    }
    .wpDataTable {
    border: 2px solid #e0e0e0;
    }

    Does put a border around the table – still no borders in the internal columns.

    The header & body of the table have different color borders – the header of the table should have a border of 9c0621 and the body has e0e0e0

    I couldn’t find any classes that would allow this to be over overridden separately.

    I don’t think you are going to easily be able to correct the issue with CSS alone – WPDataTables plugin code is changing the border and cell background colors depending on which row or column is active (highlighted). Also has color changes when hovering – also different formatting for odd/even rows

    Would be a lot of work to identify and code all the css to emulate the WPDataTables formatting. ,

    I left WP Google Maps Pro activated. So what you see at the page is what is being generated by the CSS above

    Tazewell County Pioneer Certificates

    Think I previously sent a screen shot of what it looks like when plugin is deactivated.

    Also noticed there was another report of this problem but I can’t read the private parts to determine if a solution was found:

    conflict with wpdatatable plugin

    Thanks,
    Mike

    #33757

    Hi Mike,

    Thanks for the response.

    I believe that I have found the cause of the issue and a fix for it.

    Would you perhaps be open to creating a temporary admin account for me so that I can fix this for you ASAP?

    Kind regards,
    Dylan

    #33758
    tcghs
    Member

    Dylan,

    Great!

    I removed the custom css.

    Here’s the admin account credentials:

    http://www.tcghs.net/wp-admin

    User: wpdt

    Password: dKCzVLwy#sv7#xkq!xfFKE)N

    If it’s a ton a work, I can live without it for a while – my site isn’t in production yet. But, I’d like to know when it’s fixed.

    Thanks for all your efforts!
    Mike

    #33764

    Hi Mike,

    Thanks. I have removed both of our scripts with our custom CSS for the datatables and it is displaying oddly now. I do not think this is how it should be displayed?

    Could I please ask if you could send me a screenshot again of how it should look?

    Kind regards,
    Dylan

    #33767
    tcghs
    Member

    I’ve again attached the screenshot of how it should look.

    Thanks,
    Mike

    Attachments:
    You must be logged in to view attached files.
    #33801

    Hi Mike,

    Thanks. I have fixed it.

    Can you please have a look on your side now and confirm if it is working correctly?

    Kind regards,
    Dylan

    #33804
    tcghs
    Member

    Dylan,

    Thanks much for your perseverance!

    Looks great – I assume it’ll be part of a future update?

    I’m going to disable the temporary admin login – if for some reason, you still need it, let me know.

    Mike

    #33805

    Hi Mike,

    I am glad to hear this helped.

    This will definitely be fixed in the future update, thanks for your time and patience in this.

    You can disable the admin account.

    If you have a moment to spare, could you please consider leaving a review here – https://wordpress.org/support/plugin/wp-google-maps/reviews/?

    It would really mean a lot to us.

    Have a great week further.

    Kind regards,
    Dylan

    #33904

    Hi Mike,

    To remove these two options, please open the file wp-content/plugins/wp-google-maps-pro/wp-google-maps-pro.php and go to the following code:
    “.__(“Walking”,”wp-google-maps”).”
    “.__(“Transit”,”wp-google-maps”).”
    “.__(“Bicycling”,”wp-google-maps”).”

    To remove ‘Walking’ remove the line:
    “.__(“Walking”,”wp-google-maps”).”

    To remove ‘Biking’ remove the line:
    “.__(“Bicycling”,”wp-google-maps”).”

    After saving the file, please clear your cache and test it again.

    Kind regards,
    Dylan

    #33914

    Hi Mike,

    I am happy to hear that.

    Please let me know if there is anything else that I can assist you with.

    Thanks for your time and patience.

    Kind regards,
    Dylan

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.