Popup only displays image after using Store Locator search form

New home Forums Pro Add-on General queries Popup only displays image after using Store Locator search form

Tagged: 

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #22027
    bridgetwes
    Member

    Hi,

    The marker popups display correctly until the Store Locator form is used. After that, only the image displays and all the other information is gone. I tested using the Twenty Sixteen theme, and it still behaves the same way. The site is on a staging server and not live yet, so I will respond in a private post with access to the site.

    #22028
    bridgetwes
    Member
    This reply has been marked as private.
    #22225
    bridgetwes
    Member

    Hi – the site is live now so new page is here: Aldo Leopold Map

    The only popup with an image is in Arizona to show what is happening. We would like to add photos to all the popups, but after doing a “Store Locator” search the popups only display the photo if there is a photo to display – and none of the information.

    So again the issue is:
    Click on the marker in Arizona and the popup displays fine. But if you do a search for ‘Arizona’ and then click the marker, the image displays bigger and no text displays. This happens when I use the Twenty Sixteen theme too so it isn’t something in my theme causing the issue. Is there a way to fix this?

    • This reply was modified 5 years, 10 months ago by bridgetwes.
    #22805
    SupportTeam
    Moderator

    Hi Bridget

    My sincerest apologies for us only getting back to you on this now.

    This is a minor bug in the plugin at the moment. Would it be possible for you to create a temporary admin account on your site so that I can login and sort this out for you ASAP?

    #22820
    bridgetwes
    Member
    This reply has been marked as private.
    #24255
    SupportTeam
    Moderator
    This reply has been marked as private.
    #24285
    bridgetwes
    Member

    Yes, we are still waiting for the fix for how photos display in the popup
    after filtering the results. Also, I just noticed if you search by zip
    code, it’s causing a javascript error (searching by a location name
    doesn’t):
    “Uncaught TypeError: Cannot read property ‘match’ of undefined
    at searchLocations (autoptimize_a0690f4b87999364a3eaf1e3d9fcd230.js:329)
    at HTMLInputElement.onclick (www.aldoleopold.org/:10)”

    Can we get both the issues fixed? Our map is located here:

    LEP State Coordinators

    The marker popup in Arizona has a photo in it so you can see what is going
    on (other photos in popups were removed until this issue is fixed). After you search by Arizona and click on the only marker in Arizona. The photo in the popup now displays really big.

    If you search by zip code, nothing happens, but I see the javascript error
    I noted above in my console.

    Thank you,
    Bridget

    #24302
    Dylan
    Moderator
    This reply has been marked as private.
    #24329
    bridgetwes
    Member

    Hi Dylan,

    I don’t want to enable the WordPress code editor on a live site. I verified the image showing up too big in the infowindow after doing a store locator search happens with the twenty-sixteen theme with no other plugins installed so it must be happening for all your users. Basically the Settings->InfoWindows[tab]->Default Image Width: isn’t staying set after a store locator search. Can you update your plugin with a fix and release a new version, or if you aren’t ready to release, send me an updated plugin and ensure the fix gets into your next version so I can continue updating the WPGoogle Maps and Pro plugins without the issue coming back?

    I just tested a store locator search by zip code on a site without any other plugins and it is working on that site. Not sure why it isn’t working on my staging site for Aldo Leopold with all other plugins turned off and the twenty-sixteen theme activated, but I’ll continue looking into that and get back to you. Maybe it is a particular setting that is causing that issue.

    Bridget

    #24331
    bridgetwes
    Member

    I just figured out when using a zip code in the store locator doesn’t work. It happens when the Store Locator setting “Restrict to country:” = “United States” instead of “No Country Selected”. This happens on my test site with no other plugins installed except WPGoogle Maps and Pro, and using the Twenty-sixteen theme.

    #24341
    Dylan
    Moderator

    Hi Bridget,

    I completely understand, and would be more than happy to send you a custom version of the plugin.

    Please create a new support ticket here: http://www.wpgmaps.com/contact-us/ – As this will be the easiest way to exchange the new file with you due to file upload limitations on the forum.

    The store locator altering the thumbnail width was a known issue at some point during development, however a fix was developed for this. This is the primary reason why I was hoping to debug the issue further on your site. However I will simply run detailed tests on my side to reproduce this on my side and develop a fix as soon as possible.

    Could I ask that you send through your store locator and info window settings so that I can replicate the environment on my side?

    With regards to the ZIP code search. The plugin attempts to determine whether the entered value is an address, in order to determine if geocoding needs to be done to find the center point.

    Depending on the data entered, the results of these tests vary. Our solution to this issue is to force geolocation on all entered values.

    However we are developing a more stable work around for this at the moment.

    When submitting your support request, please reference this topic so that we can get this sorted ASAP for you.

    #24364
    bridgetwes
    Member

    Thanks – I just submitted a new support ticket through the link you provided.

    #24378
    Dylan
    Moderator

    Hi Bridget,

    Thank you so much, I will be looking into this along with out team ASAP.

    We really appreciate your time.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.