Plugin v8 Installation and Activation issue

New home Forums Basic Version Troubleshooting Plugin v8 Installation and Activation issue

  • This topic has 3 replies, 1 voice, and was last updated 4 weeks ago by Nick Duncan.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #66554
    bardiadaniari
    Participant

    Hi there,

    After the recent update of WP Google Maps Basic & Pro versions (v.8), I have tried to update and activate the plugin according to the documentation. Unfortunately, I have been facing the following error within the WP admin panel, whether I try to activate the Basic plugin (v 8.1.1) on the Parent theme level or the child theme of the application:

    Fatal error: Class 'WPGMZA\Page' not found in /srv/www/sv-voting-php7/public_html/wp-content/plugins/wp-google-maps/includes/class.settings-page.php on line 5

    Following forum threads, it was suggested that this could be a namespace issue with older versions of PHP, however, my application is running on PHP7.

    I have tried the installation both according to the tutorials provided through WP admin and the alternative of downloading and installing the files manually within the folder. I also tried activating the Pro plugin before activating the basic version.

    Ive attached a few screenshots as well.

    Your advice is most appreciated.

    Attachments:
    You must be logged in to view attached files.
    #66604
    Nick Duncan
    Keymaster

    Hi there
    I’m terribly sorry about that issue.
    We had a botched release with 8.1.0 which caused a fatal error. Please ensure you are using 8.1.2.
    In order to fix this, you would need to manually remove the wp-google-maps plugin from your FTP and reinstall the latest version in wp-admin.

    Sorry about that.

    Kind regards
    Nick

    #66903
    bardiadaniari
    Participant

    Hi there,

    Thanks for the instructions. I followed the steps as outlined and upgraded to a later version (8.1.4 appeared to be available). However, the same error seems to appear as before when i attempt to activate the plugin.

    Your advice is most appreciated.

    Best regards,
    Bardia

    Attachments:
    You must be logged in to view attached files.
    #66929
    Nick Duncan
    Keymaster

    Hi Bardia
    Please can you send me a temp admin account via a private reply and I will make sure everything is installed and working properly for you.

    #67007
    bardiadaniari
    Participant

    Hi Nick,

    Thank you for your reply.
    Unfortunately I am not authorized to share the application administration rights.
    On the other hand it would help if you could clarify a little further on the state of the v8 plugin upgrade and the discontinued support for the previous versions. For example, will the plugin fail to work over the next few months or only when other features within the application are upgraded further. Or will there simply be no support from the developers but the previous versions will continue to function as before.

    Your advice is most appreciated.
    Bardia

    #67016
    Nick Duncan
    Keymaster

    Hi Bardia
    Version 8 will continue to be supported for the next few years. Our plan is never to leave a major version in an unusable state. If that does ever happen, we upgrade our users for free to the latest major version (we just did this actually – all v5, v6, and v7 users were upgraded to v8 due to the major structural changes of v8.1)

    Kind regards
    Nick

    #67248
    bardiadaniari
    Participant

    Hi Nick,

    Thanks for the reply.
    Could you clarify a little further about the state of the previous versions. ie. version 7. Such as its limitations over version 8, and how the support of version 7 would change over the foreseeable future eg. a roadmap.

    Your advice is most appreciated.

    Regards,
    Bardia

    #67259
    Nick Duncan
    Keymaster

    Hi Bardia
    All customers should now be using version 8. Anything below version 8 is no longer supported. As mentioned, we automatically upgraded all users for free to version 8 because we decided to no longer support versions below version 8.

    We will continue to support version 8 for the foreseeable future while at the same time supporting version 9 and so on.

    Kind regards
    Nick

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.