oops no map and no API field to save API in !

New home Forums Pro Add-on General queries oops no map and no API field to save API in !

This topic contains 10 replies, has 2 voices, and was last updated by  SupportTeam 3 years ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #21128

    mummygeek
    Member

    I have created my API key but having gone through all documentation I see there is no field in which to paste it on the Settings>Advanced tab in the Plugin screens.
    no API field

    When trying to add a map I get the Oops image. Oops! Something went wrong.
    This page didn’t load Google Maps correctly. See the JavaScript console for technical details.

    Where can I save my API key?
    On the mydomain/wp/admin.php?page=wp-google-maps-menu or Maps>Maps screen I get an important notification asking for my API key which I paste in and save but it is never acknowledged; I see exactly the same prompt next time…

    Look forward to some help and really hope I’m not missing the obvious.

    • This topic was modified 2 years, 7 months ago by  SupportTeam.
    #21129

    mummygeek
    Member

    no API field

    #21136

    SupportTeam
    Moderator

    Hi there

    Please send me a link to your map so that I can look further into this for you?

    #21176

    mummygeek
    Member

    Hi Jarryd,

    HERE there should be a map showing on my home page in progress.

    This is a recently bought wordpress theme from Johnthemes via envato – the theme files included various plugins.

    ‘WP Google maps’ and ‘Pro Add on’ were included. I have versions v 6.3.19 and v 5.49 respectively.

    I cannot see where to add my Google API key – the field for it on the settings>advanced tab, as shown in your documentation is not there.

    When I go to the Maps>maps page in my admin area I see the important notification
    I paste my API key into the field and save it but there is no sign of it actually being saved because each time i go back to this page i see the same message, as if my API key was not saved previously.

    The maps throughout the admin area and front end do the same: the world map is visible brieflyfor a second and then the Ooops msg everytime.

    Look forward to hearing…

    #21200

    SupportTeam
    Moderator

    Hi there

    Unfortunately you’re using outdated versions of our plugin.

    Please update your basic version to 6.3.20 and Pro version to 5.73.

    Should you need a new download link for the Pro version, please go to http://www.wpgmaps.com/get-updated-version

    #21220

    mummygeek
    Member

    Hi Done the update on both plugins and I have been able to save my API key now but the map outputs are exactly the same “This page didn’t load Google Maps correctly. See the JavaScript console for technical details.”

    No maps are showing in the admin area either – if that helps…
    ?

    #21229

    SupportTeam
    Moderator

    Hi there

    Please send me a link to your map so that I can look into this for you?

    #21240

    mummygeek
    Member

    Hi, Link

    #21253

    SupportTeam
    Moderator

    Hi there

    The Google Maps API is returning the error ‘ApiNotActivatedMapError’. To fix this, please login to your Google Developers Console, go to ‘Libraries’, click on ‘Google Maps JavaScript API’ and then on the ‘Enable’ button at the top of the page.

    Does this help?

    #21257

    mummygeek
    Member

    Sorry for missing something so elementary. Thanks for your time !

    #21342

    SupportTeam
    Moderator

    Hi there

    Not a problem at all. Happy to have been of assistance 🙂

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.