New markers taking long to show on map

New home Forums Basic Version Troubleshooting New markers taking long to show on map

Tagged: , ,

  • This topic has 9 replies, 4 voices, and was last updated 2 weeks ago by Matthew.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #79782
    mhorvath
    Participant

    Hey, I’ve been using the map for a few months now. In the past week I had to add some new markers to the map an realized that they don’t really show up on the map for quite a long time, also differing between different users and browsers. Some may be able to see the newly added markers, others are not.

    To my process: I added the markers manually to the list and made sure that the “show on website” is marked with “yes” on all of them. After that I save the map and flush the page cache. Still it often takes mutliple tries on my end or separately clearing my own cache before the markers show up on my end. For other users it often takes longer. I’m using the pro-add on, but since I figured this could maybe also be an issue for the basic version I’m posting it here.

    What can I do to show newly added markers on the map immediately (or at least faster)?

    #79796
    glen
    Moderator

    Hi There

    Thanks for getting in touch, I am so sorry you are experiencing some difficulty displaying markers on the front end

    Markers that are added should be visible on the Front end immediately.

    It might be the case however that you are running an optimisation plugin that is caching the Rest API, if that is the case, I would recommend turning off Rest API caching while editing your map.

    If you are not caching the REST api, and continue to experience this issue, please will you share a link to your map page (this can be marked as private) so we can look into this further

    Kindest Regards,
    Glen

    --------
    WP Go Maps Support Staff

    #79802
    Tim Sullivan
    Participant

    Hello,
    I’m experiencing the same problem with markers taking a long time to appear after editing or creating new ones.

    We are hoping to roll this out soon and have about 80+ locations but they will be changing and getting updated on a monthly basis.

    Our test site is below (thanks in advance)

    Distribution Map – Test

    #79806
    Matthew
    Moderator

    Hi @Tim,

    Thank you for getting in touch with us, we do appreciate your time.

    I have taken a look at your map and it appears that there are 85 markers loaded on your map.

    I see that you have the “XML” marker pull method selected, thus please may we ask if you may use the “Database” marker pull method instead as this is faster and more reliable?

    You may also use the WP REST Cache plugin (by acato) to improve loading speeds as it caches the REST API calls.

    We hope this helps?

    Kindest Regards,
    Matthew

    #79900
    Tim Sullivan
    Participant

    Hi Matthew,
    Thanks for the reply. I’ve made those suggestions (including the REST Cache)
    Still fighting browser caching when a marker is updated. The updates from the admin area and point of view work great but anything on the live site takes a long time to show up.

    Thanks in advance and let me know if you need any other details
    -t

    #79904
    Matthew
    Moderator

    Hi there,

    Thank you for your response.

    I have taken a look at your map on my end, and it appears that the markers took 0.31 seconds to load on the map.

    Please may you confirm if you experience the same thing when viewing your site again? The REST Cache does take some time to build the cached data to be served, thus the first few times that you viewed your map, it may not have served the cached data as it may not have had the data to serve.

    I look forward to hearing back from you.

    Kindest Regards,
    Matthew

    #79906
    Tim Sullivan
    Participant

    Hi Matthew,
    Thanks, correct, the markers load from the front end correctly.
    However, if we have an admin editing listings or adding new ones it’s not apparent on the front end (at least immediately even if logged in as an admin)

    Perhaps this is normal? If we purge the REST cache should we expect to not see updates for a given amount of time (5 minutes or an hour, day later?)

    Thanks again, appreciate your help!

    #79909
    Matthew
    Moderator

    Hi Tim,

    Thank you for your response.

    When you make updates, you would need to clear the REST cache as the plugin would need to build the new cached data in order to serve the updated content.

    However, you should be able to load the map a few times which should help the WP REST Cache plugin to build the cache to be served.

    I hope this answers your question?

    Kindest Regards,
    Matthew

    #79917
    Tim Sullivan
    Participant

    Hi Matthew,
    Thanks again
    Here’s what we’re seeing across several machines/browsers

    Edit a map marker
    save
    save map
    clear rest cache

    Load page and view (correctly shows update)

    Edit the same map marker
    save
    save map
    clear rest cache

    load page a view (updates are not reflected) I can also verify that coming back to that page even a day later did not reflect new updates

    I suspect what’s happening is the map is loaded and cached locally within each browser session, if so how would we force those map instances to load again with updated data?

    Best
    -t

    #79937
    Matthew
    Moderator

    Hi there,

    Thank you for your response.

    Please may you confirm if you have any other caching solutions installed on your site, and if so please may you also clear that cache?

    I do not believe that the browser cache would affect this, however, you may try clearing your browser cache by pressing Ctrl+F5 which will hard-refresh the tab without any cache.

    You may also try disabling compressed path variables to see if this helps by sending the raw REST request (Maps -> Settings -> Miscellaneous / Advanced Settings).

    I hope this helps?

    Kindest Regards,
    Matthew

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.