multibyte support plz

New home Forums Visitor Generated Markers multibyte support plz

This topic contains 5 replies, has 2 voices, and was last updated by  hopper 11 months, 3 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #43149

    hopper
    Member

    I bought pro-add-on 2 days ago. your both plugin and support is very nice.

    As see in attchment image, there’s some trouble on multibite language at demo site. (鳥取駅 means Tottori Station)

    If this trouble has solved, I’d buy this add-on. please fix it.

    Best regard
    hopper

    Attachments:
    You must be logged in to view attached files.
    #43159

    Hi Hopper,

    Thanks for getting in touch with us.

    These translations can be edited by changing the .PO files inside the folder wp-content/plugins/wp-google-maps/languages/ and opening the PO file with the language code in the name. You will need a PO editing application such as https://poedit.net/ to edit these files.

    Please let me know if this helps.

    Kind regards,
    Dylan

    #43450

    hopper
    Member

    Hi Dylan

    I’m grad to see your fast reply. Thanks.

    I inputed Japanese text. And want to display Japanese text.
    So, this is not “translation” issue.

    Multibyte probrem often occure in Japanese develop scene.
    I’ve seen similar bugs before. It sometimes caused by file format.
    I often cleared replacing ????? bugs by changing “SJIS” format to “UTF-8” on text editor.
    (SJIS is typically used format in Japan)

    If you can search in related files of VGM, please check if these files written in UTF-8 or mutibyte supported format.

    Best regard
    Hopper

    #43452

    hopper
    Member

    or may have solve by using “unicode escaping” like

    鳥取駅 —> \u9ce5\u53d6\u99c5

    #43462

    Hi Hopper,

    Thanks for the response and apologies for the delay over the weekend.

    Could I kindly ask if you could send me a link to your website so that I can take a closer look at this and assist you further.

    Kind regards,
    Dylan

    #43467

    hopper
    Member

    Hi Dylan

    Location “鳥取駅(Tottori station)” is here( https://goo.gl/maps/g5bqFsjKQqS2 ) on GoogleMap
    and I pinned similar location on your VGM demo page map and titled Japanese.
    Also today, I can see same ???? titled displayed Tottori Station on demo ( https://www.wpgmaps.com/demo/visitor-generated-markers/ )
    Now, I wonderd if I buy this plugin.

    Sorry for confusing explanation on first message.
    I bought pro-add-on but NOT VGM-add-on. So I’m still not using VGM on my site.
    This problem happened on your demo site. Could you check on demo site please? Especially, Japan, Korea, Russia’s multibyte characters.

    Best regard
    Hopper

    • This reply was modified 11 months, 3 weeks ago by  hopper.
    #43470

    Hi Hopper,

    Thanks for the response.

    I had a further look at this and noticed that it only happens with the marker title and when adding the Japanese text in the description it displays correctly.

    I have added this to the todo list to get this resolved in a future release.

    I hope this helps.

    Kind regards,
    Dylan

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.