Move infoboxes below map

New home Forums Gold Add-on Troubleshooting Move infoboxes below map

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #77477
    Kristine
    Participant

    Hi!
    I have added the WP go maps on my wordpress site. I have added 6 different markers. Now all of these 6 markers are listed next to each other, above the map. I don´t want them there, but I don´t find any setting on how to remove/move these, only on how to change colours (sun, earth etc). I would also change the way they appear, for example that not all of them are next to each other, but perhaps two and two. I don´t know anything about coding, so I would need a guide on how to fint the settings for this. I use the Atlas Novus.

    Best regards, Kristine

    #77485
    Matthew
    Moderator

    Hi Kristine,

    Thank you for getting in touch with us and using WP Go Maps, we do appreciate your time.

    Please may I ask if you would be open to providing me with the link to your map page so that I may take a closer look and advise?

    I look forward to hearing back from you.

    Kindest Regards,
    Matthew

    #77487
    Kristine
    Participant
    This reply has been marked as private.
    #77495
    Matthew
    Moderator

    Hi Kristine,

    Thank you for getting back to me and for your time on this.

    Thank you for the link, however, it results in a “page not found” message which is most likely caused due to the page not being published yet.

    Would you possible be able to publish the page with a password and possibly provide me with the password to view the page?

    I look forward to hearing back from you.

    Kindest Regards,
    Matthew

    #77496
    Kristine
    Participant
    This reply has been marked as private.
    #77528
    Kristine
    Participant

    Is it possible to get an answer to this soon?:)

    #77531
    Matthew
    Moderator

    Hi Kristine,

    Thank you for your response and my apologies for the delay.

    Thank you for the link, I have taken a look and found that you are referring to the carousel marker listing. You may disable this feature by setting the marker listing style to “None” (Maps -> Edit -> Settings -> Marker Listing -> General).

    Alternatively, if you would like to keep the marker listing above the map, however, change the number of items displayed, you may do this using the “Desktop Items, Tablet Items, Mobile Items” setting in the “Device Settings” section (Maps -> Settings -> Marker Listing).

    Please do let me know if this helps?

    Kindest Regards,
    Matthew

    #77550
    Kristine
    Participant

    Thank you, it helped!
    I have some more questions, though.
    1: I changed the marker listing setting to “grid”, and I like it on the desktop view. But it looks horrible in mobile view. How do I customize it, so it looks better on a smaller screen? The box where all my markers are are also very big on mobile view. Do I need som CSS to fix this, or are there already finished solutions?

    2. Now, in “grid view”, the link I have on each marker is above the title. I don´t want it to be there, and I would also like to adjust what content on each marker that are visible in this grid-view. Is that possible?

    #77585
    Matthew
    Moderator

    Hi Kristine,

    Thank you for your response and I am glad to hear that disabling the marker listing helped.

    1. Some custom CSS code can resolve this mobile styling, thus please may you save the below code into the “Custom CSS” setting block (Maps -> Settings -> Custom Scripts), clear your browser cache and confirm if this helps:

    @media screen and (max-width: 876px){
        .wpgmza-standalone-component .wpgmza-marker-grid, .wpgmza_map .wpgmza-inner-stack .wpgmza-marker-grid{
            grid-template-columns: repeat(2, 1fr);
        }
    }
    
    @media screen and (max-width: 576px){
        .wpgmza-standalone-component .wpgmza-marker-grid, .wpgmza_map .wpgmza-inner-stack .wpgmza-marker-grid{
            grid-template-columns: repeat(1, 1fr);
        }
    }

    2. I see that you may have managed to hide and show specific content in your marker listing grid items, however, if you still require assistance, you may find these settings by navigating through to Maps -> Settings -> Marker Listing.

    I hope this helps?

    Kindest Regards,
    Matthew

    #77607
    Kristine
    Participant

    Thank you for your answer. I managed to hide some content, and I also found out how to view only 1 column in mobile view.

    I have two more questions as well, that I can´t figure out.

    1. The filter box is covering the entire map in mobile view. How can I get this to look good? I have placed it to be in the bottom left in the map, which works fine on desktop view, but not on mobile view. Is there a way to get this filter box to be smaller, or horizontally, not vertically, only on mobile view, without changing the position in desktop view?

    2. I want to change the zoom control. Now, when I scroll down my webpage, when the cursor hovers over the map, the scrolling starts to zoom in the map. I don´t want this to happen.I would rather make it so the zooming starts when you scroll with only one finger. How can I change these settings?

    Kristine

    #77640
    Matthew
    Moderator

    Hi Kristine,

    Thank you so much for your response and time on this.

    1. I have taken a look at your map and it appears that your filter is displayed above the map, thus please may you confirm if you would still like the filter checkboxes to be displayed horizontally on smaller screens?

    2. You would need to disable the “Greedy Gestures” feature which you may find by navigating to (Maps -> Settings -> General Settings).

    Please do let me know if this helps?

    Kindest Regards,
    Matthew

    #77642
    Kristine
    Participant

    Thank you for your answer about the zoom control. It worked.

    Yes, I tried to move the “filter by” above the map. But I don´t think it looks good, so I don´t want it there. On desktop view I would want it to be inside the map, in the corner. But on mobile view it covers the entire map. What are the solutions for this matter with filter options on mobie view? I guess others have the same problem.

    Another thing is that my pictures are not visible in the info box view anymore, only in the marker listing underneath the map. How can I get the pictures back again in the info box?

    and – since my webpage is in NOrwegian, is there a way to change or remore the “filter by” sentence?

    #77655
    Matthew
    Moderator

    Hi Kristine,

    I am happy to hear that disabling the Greedy Gestures feature helped.

    With regards to the category filter, restyling the filter when it is outside and above the map is possible, thus if this would be better for you after it is restyled, I am more than happy to assist you with the restyling thus please let me know.

    The best solution for mobile is the above as this is mainly what users opt for especially if there are many categories to filter by.

    Lastly regarding the infowindow images no longer being displayed, it appears that your “Hide the gallery/image field” setting is enabled (Maps -> Settings -> Infowindows), thus please may you disable this setting and confirm if this helps?

    Kindest Regards,
    Matthew

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.