Marker zoom feature

New home Forums Pro Add-on Marker zoom feature

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #61803
    Konrad
    Participant

    Hi,

    I’ve been testing pro version for couple last days and I’d like to develop my map with a feature, that shows one general marker with amount of markers (locations) in the area that is covered by the general marker. When the map is getting zoomed the general marker starts splitting into more accurate markers until the view is zoomed enough to show exact location. I hope I described this well enough. Is this possible?

    I’m also experiencing two issues:

    1. I have over 400 markers added to my map. It seems, this impacts a performance of the map? Is there a way I can make the map working more smooth?

    2. Theme change doesn’t work. If I select one, a code appears in “Theme Data” field, but after saving the map doesn’t change. “Open Theme Editor” button doesn’t work either. Is this a known issue?

    Any help will be appreciated.

    Thanks,
    Konrad

    • This topic was modified 3 years, 5 months ago by Konrad.
    • This topic was modified 3 years, 5 months ago by Konrad.
    #61807
    AbelC
    Moderator

    Hi Konrad,

    Thank you so much for getting in touch with us.

    This can be achieved with our marker clustering feature. This will allow you to group the markers together and only display one marker.

    Please see our demo here -> https://www.wpgmaps.com/demo/marker-clustering/

    Please also see our documentation here -> https://www.wpgmaps.com/documentation/how-to-create-a-marker-cluster-group/

    Please note that this feature is included in our WP Google Maps Gold add-on (https://www.wpgmaps.com/gold-add-on/).

    Regarding the issues you experience, please find my response below:

    1. Could I kindly ask if you could please provide me with a link to your map page?

    Could you also please confirm the steps you took to reproduce this issue as this will allow us to take a closer look at what is causing this issue?

    2. Unfortunately, we were unable to reproduce this issue on our side. We do apologize for the inconvenience.

    Could I kindly ask if you could please confirm the WP Google Maps versions installed on your side?

    Please note that clicking on the “Open Theme Editor” button will open the theme editor box on the right side of the page. Please see the screenshot below:
    https://drive.google.com/file/d/15MX9bGXX7YnQxwKpn_f_LTTIN8oYxg4n/view?usp=sharing

    I hope this helps clarify, and I look forward to hearing back from you.

    Kind Regards,
    Abel

    #61818
    Konrad
    Participant

    Hi Abel,

    Thank you for your prompt reply.

    Gold add-on – thanks. I missed that.

    1. Here’s the link: https://pvtec.pl/mapa-instalacji/
    I prepared a .csv file with required columns and datas and imported the markers. As you can see, the map is very basic and I can’t think why this is lagging so hard.

    2. Installed version is 8.0.34. Unfortunately, I don’t get this window after a click on the button. As I mentioned, if I select one of the available themes, code shows in Theme Data, but after save nothing changes. See attached screenshot

    Kind regards,
    Konrad

    Attachments:
    You must be logged in to view attached files.
    #61833
    AbelC
    Moderator

    Hi Konrad,

    Thank you so much for getting back to me.

    1. Could I kindly ask if you could please navigate to Maps -> Settings -> Scroll down to “Tile Server URL” -> Please switch to a different tile server (Example: Wikimedia Maps) to see if this resolves the issue you are currently experiencing?

    2. It appears that you have selected the OpenLayers map engine (Maps -> Settings -> Maps Engine).

    Unfortunately, it is not supported to select a theme for the OpenLayers map at the moment. We do apologize for the inconvenience.

    I hope this helps clarify, and I look forward to hearing back from you.

    Kind Regards,
    Abel

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.