Marker order in a mash-up map

New home Forums Pro Add-on General queries Marker order in a mash-up map

Tagged: 

Viewing 15 posts - 1 through 15 (of 87 total)
  • Author
    Posts
  • #31871
    agrudick
    Member

    The marker order criteria are working properly in all of my individual maps but not in my mash-up map. No matter what marker order criterion I select for the mash-up map on the parent map, my markers below the mash-up map always appear in decending ID order. I would like my markers below the mash-up map to appear in ascending order by title.

    Map #2 is the parent map for my mashup map. My mash-up map appears on the page titled “all locations”.

    My website is streetartmap.org. Your IP address 45.220.43.49 has been whitelisted. – Art

    • This topic was modified 4 years, 10 months ago by agrudick.
    #31899
    Perry
    Moderator

    Hi Art

    Thanks for getting in touch, and thank you for bringing this issue to my attention.

    I’m going to make a note to patch this in the current version as soon as possible.

    In the mean time, would you be interested in trying out a beta of the next release? This has been solved already,

    Please let me know?

    Kind regards
    – Perry

    #31911
    agrudick
    Member

    Yes I would like to try out the beta of the next release. What do I need to do to receive it? – Art

    #31915
    Perry
    Moderator

    Hi Art,

    Ideally, I’d need your FTP details and access to your dashboard – that way if there are any problems installing it I can solve them straight away.

    If that’s not possible I’ll give you the ZIP files to do this yourself, you would need to backup and delete your old folders and manually install the plugin.

    Kind regards
    – Perry

    #31950
    agrudick
    Member
    This reply has been marked as private.
    #31955
    Perry
    Moderator

    Hi Art

    Unfortunately that’s not my IP address, I imagine that’s the mail server, my IP address is 82.68.127.126, if you could whitelist that that would be great,

    I will need your FTP username and password to continue (as opposed to your dashboard username and password), or access to your cPanel / hosting if you would like me to set the FTP account up,

    Please let me know?

    Kind regards
    – Perry

    #31972
    agrudick
    Member
    This reply has been marked as private.
    #32001
    Perry
    Moderator

    Hi Art

    I’ve installed the beta and completed the migration, I did look on the “All Locations” page but I don’t see a marker listing below the map – can you please confirm whether or not this is a mistake?

    I’m assuming that the marker listing style hasn’t migrated correctly, please let me know,

    Kind regards
    – Perry

    #32003
    Perry
    Moderator

    Hi Art,

    I took a close look at the raw V6 data and I can see that you had your listings set on “Basic table”, I’ve corrected this on all the maps and patched the issue in the migrator, thanks for helping me find this!

    Please let me know if you notice anything else wrong?

    Kind regards
    – Perry

    #32019
    agrudick
    Member
    This reply has been marked as private.
    #32035
    Perry
    Moderator

    Hi Art

    Thanks for your patience with this, please bear with me, I’ll have all these points addressed this morning

    This feedback is very useful to me, please keep it coming 🙂

    I’ll be in touch once I’ve completed those adjustments,

    Kind regards
    – Perry

    #32045
    Perry
    Moderator

    Hi Art

    Just to keep you updated, I’ve addressed the first and last points (missing columns in admin marker table, scroll bar on admin category list), I’ll be with you first thing tomorrow to address the other two points,

    I’m so sorry I didn’t get these done today, we’re on bare bones today as the bulk of the staff are away at a conference,

    I’m looking into the marker order direction not being respected now, if I don’t get this solved today I’ll get back on this first thing in the morning before I deal with anyone else,

    Thanks again for your patience on this matter

    Kind regards
    – Perry

    #32062
    agrudick
    Member
    This reply has been marked as private.
    #32067
    Perry
    Moderator

    Hi Art,

    I’ve addressed the other two points from yesterday

    – The map now zooms in 3 clicks above maximum when you click a marker
    – As far as I can tell, the marker listing order is being respected for map ID 12 (categories ascending), I’m going to address the descending setting not being respected as soon as possible

    Regarding points 5 through 10,

    5) I’m going to change the behaviour of this field

    6) I’ve found the same thing when testing, I’m going to merge these into one “Save Marker” button. At the moment, update marker commits the changes, finish editing deselects the marker without committing any changes, sorry this is unclear

    7) This has been the default behaviour of the directions box for some time, I’ve copied this exactly from 6.16, I’d like to look at changing this as I absolutely agree, but I don’t know if this will happen in a future version. If you’d like to customise the behaviour on your site then we can absolutely do that, just let me know what behaviour you would like?

    8) Can you please give me steps to reproduce this? Is it on any marker in particular?

    9) Which browser are you using? I haven’t written any code to change the cursor in the map edit page, I think this is probably an issue outside of my control, I’d be happy to look into it though

    10) Again, if you could give me exact steps to reproduce this I’d be happy to fix it, I tested this out and the paragraph and link were formatted correctly in both the infowindow and the marker listing

    I’m very grateful for the feedback, please do keep it coming, and thanks again for your patience!

    Kind regards
    – Perry

    #32092
    agrudick
    Member

    Perry,

    Here are my latest responses and comments:

    2. Thank you for making that change. I would like to make one more adjustment. Here is the current operating sequence:
    Step 1: The user clicks on one of the markers in the table below the map.
    Step 2: The display automatically scrolls to the top to show the map.
    Step 3: The selected marker appears centered in map. The zoom setting does not change from whatever the previous zoom setting was.
    Step 4: The user clicks on the selected marker on the map.
    Step 5: The zoom setting goes to 3 clicks out from the tightest possible zoom and the info box and the selected marker appear approximately centered in the map.

    I would like to eliminate steps 3 and 4. and go straight to step 5 when the scroll up is complete.

    7. The reason I thought that the “get directions” box was a new feature is that I never saw it in the previous version. Was it off by default in the previous version? In the previous version when I clicked on the highlighted “directions” text it took me straight to Google Maps with no “get directions” box ever appearing. Is there a way to turn off the get directions box? Is it possible to go straight to Google Maps without the “get directions” box ever coming up?

    8. Here are the steps that I followed:
    Step 1: type the search text into the marker search box
    Step 2: click on the edit icon for the marker located by the search
    Step 3: scroll up to edit the marker’s parameters
    After step 2, most of the time only the previously selected category was selected (as would be expected). However maybe about 10% of the time all of the categories came up hi-lited.

    10. Go to map 6 titled “Other Neighborhoods” You can see an actual example of what happens.

    I typed some sample text and a sample link into the description box of Marker ID 133. When viewing the site both the sample text and the sample link appear in the pop-up info box. Neither the sample text nor the sample link appear in the marker table below the map.

    I typed the same sample text and the same sample link into the description box of Marker ID 177. I surrounded both with “<p>…..</p>. When viewing the site both the sample text and the sample link appear in both the pop-up info box and in the marker table below the map.

    11. (new) On the “Layout” tab of the map settings. I can drag and drop the boxes on my tablet (Samsung Tab A 10.1) However on my phone (Samsung Galaxy S7) The boxes do not respond to my attempts to move them.

    12. (new) Last night my home page slider was working as expected. This morning my home page slider has disappeared. I looked at the settings and it looks like all of the slider images and parameters still seem to be in place, but I can’t get my slider to re-appear on my home page. Is it possible that beta work that we are doing could affect my home page slider?

    Art

    • This reply was modified 4 years, 10 months ago by agrudick.
Viewing 15 posts - 1 through 15 (of 87 total)
  • You must be logged in to reply to this topic.