Marker Listing Options bugs

New home Forums Pro Add-on Troubleshooting Marker Listing Options bugs

This topic contains 11 replies, has 2 voices, and was last updated by  MilosElu 10 months, 3 weeks ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #45929

    MilosElu
    Member

    Hello again,

    I have more than a few bugs, and for now I am not satisfied.

    So, I’m shoving multiple maps on one page. I have the same settings for the filter by categories and custom fields, and I have Modern Marker Listing Options. Same for every map.
    But unfortunately, only a filter is displayed for the one map, on the other one just a button for displaying the list, and this button works for list of another map. Totally dysfunctional.

    Also, sometimes when I’m using filter, list button is over list window, somntimes it is not.

    Please help, I’ve lost a lot of time already working on this.

    ps. If I use maps mashup, custom field filters or lists are not working at all.

    • This topic was modified 10 months, 4 weeks ago by  MilosElu.
    • This topic was modified 10 months, 4 weeks ago by  MilosElu.
    Attachments:
    You must be logged in to view attached files.
    #45939

    Perry
    Moderator

    HI Milos

    Thank you for getting in touch, please accept our apologies for any inconvenience caused.

    Would it be possible for you to link us to your map page so we can take a look at this issue first hand?

    Kind regards
    – Perry

    #45943

    MilosElu
    Member
    This reply has been marked as private.
    #45952

    Perry
    Moderator

    Hi Milos

    I see, have you enabled custom field filtering for map ID 8?

    Would it be possible for us to have temporary access to this site so we can inspect your setup, copy that at our end in order to reproduce and patch the issue?

    Regarding the import, can you please try setting the “latlng” column to NULL to cause the plugin to update the spatial index? If you’ve imported without setting the spatial data up correctly then your markers would not appear.

    Regarding the Gold add-on, I’m very sorry but we don’t offer evaluation copies of our software. We do have a full refund policy set out at https://www.wpgmaps.com/terms-conditions/ , if you’re not 100% happy with the add-on we will refund you.

    I hope that helps?

    Kind regards
    – Perry

    #45957

    MilosElu
    Member
    This reply has been marked as private.
    #45959

    Perry
    Moderator

    Hi Milos

    I visited http://e3.webseff.com/e3/wp-admin/ however I see a 404 page, could you please check that?

    You cannot import custom field data with CSV files at the moment, this is due to the arbitrary nature of the data and the orthogonal nature of spreadsheets. You need to use the JSON format at the moment if you wish to import custom field data.

    You can see an example CSV at the bottom of this page: https://www.wpgmaps.com/documentation/exporting-and-importing-your-markers/ however please bear in mind you will need to use JSON if you want to work with custom field data.

    If you want to see an example of the JSON format our plugin uses, please run an export from the “Advanced” page and that will get you started.

    Our demos use the Google Maps engine, you are using OpenLayers. If you want identical infowindows, you will need to switch. Failing that we can help you tweak the OpenLayers infowindow, it would be helpful if we could have the URL to your map page in order to do so, if that’s possible?

    Kind regards
    – Perry

    #45961

    MilosElu
    Member

    Strange. URL is which I provided is correct, please just copy it, or remove /e3 in front of the wp-admin.

    Hm, I realy like OpanLayers. Don’t want use Gmaps. 🙂

    #45962

    Perry
    Moderator

    Hi Milos

    We can help you style that window in any way you need, I’d start with increasing the minimum width so it’s more letterboxed and less tall.

    I did visit http://e3.webseff.com/?page_id=83 to look at doing that however it appears you’ve switched infowindow styles.

    Regarding the mashup filtering issue, it appears this is a widespread issue, we will patch this as soon as possible. We should be able to get that out to you on or shortly after boxing day.

    I hope that helps?

    Kind regards
    – Perry

    #45964

    MilosElu
    Member

    Hi Perry

    Hm, not sure what we are talking about. For the first map Infowindow is on deafault. InfoWindow Settings default as well. And it’s very narrow. Yes, I would like to set it up like on your demo page, and use OpenLyers. Please, let me know how we are going to do that.

    Yes, any patch would be helpfull for the multiple map list and filter, but I’m already late with this project. Because of that, I would like to try one map with marker clustering options (I’ll have over 800 markers).

    Thanks

    edit: Is the marker clustering compatible with open layer? :-/

    • This reply was modified 10 months, 3 weeks ago by  MilosElu.
    • This reply was modified 10 months, 3 weeks ago by  MilosElu.
    #45967

    Perry
    Moderator

    Hi Milos

    Can you please add the following to Maps -> Settings -> Advanced under Custom CSS:

    .wpgmza_markerbox
    {
    width: 200px;
    }

    To alter the width of the infowindow. You can adjust that to taste. If you need any more CSS please let us know specifically what you’re looking to customise?

    Regarding Gold, I have asked my CEO about the possibility of an evaluation copy considering your deadline and that you need it as a workaround for our mashup issue,

    Please be advised that at present Gold does not support marker clustering – you would need to use the Google API in order to use that feature.

    Does that help?

    Kind regards
    – Perry

    #45969

    MilosElu
    Member

    Hi,

    I already buy Gold, thank you. Hope it will help.

    Marker clustering works for me without Google API.

    Please, in JSON file, would this works for custom field import?

     "custom_fields_data/Regions": "Asia",
      "custom_fields_data/Sector": "Institutional",
      "custom_fields_data/Service Category": "Capacity Development"

    or it should be (this one is more complicated for set up in Excel, and later convert into JSON):

     "custom_fields_data": {
                    "Regions": "North America",
                    "Sector": "Institutional",
                    "Service Category": "Sustainable Energy Project Development"
    }
    • This reply was modified 10 months, 3 weeks ago by  MilosElu.
    • This reply was modified 10 months, 3 weeks ago by  MilosElu.
    • This reply was modified 10 months, 3 weeks ago by  MilosElu.
    #45977

    Perry
    Moderator

    Hi Milos

    Thank you very much for your purchase 🙂

    You need to follow the latter format for JSON custom fields:

    “custom_fields_data”: {
    “Test Field”: “123 test”
    }

    This format will not work:

    “custom_fields_data/Regions”: “Asia”,
    “custom_fields_data/Sector”: “Institutional”,
    “custom_fields_data/Service Category”: “Capacity Development”

    I hope that helps?

    Kind regards
    – Perry

    #45978

    Perry
    Moderator

    Hi Milos

    Just to update you regarding the filtering and mashup issue,

    I wasn’t able to reproduce this issue locally with the same setup so I believe either we’ve missed something or this issue is unique to your site, in any case, I see you’ve changed your setup now,

    Is that still an issue you needed help with?

    Kind regards
    – Perry

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.