Marker list not showing & Processing overlay

New home Forums Visitor Generated Markers Troubleshooting Marker list not showing & Processing overlay

This topic contains 4 replies, has 2 voices, and was last updated by  poolec 6 months, 4 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #47507

    poolec
    Member

    Hi,

    With Version 7.11.02 WP Google Maps, Version 7.10.61 WP Google Maps – Pro Add-on and Version 3.09 WP Google Maps – Visitor Generated Markers everything is working fine. As soon as you upgrade WP Google Maps plus Pro and VGM the marker list does not display in either the front or back end, just shows an overlay with the word Processing.

    You can take a look at the dev version of the site where I have applied the updates so you can see the issue: https://dev05.pinneypoole.net/bmctracker/

    I’ve attached a screen shot of what it looks like in the back end view.

    The live site is not updated and is working fine here: https://www.ebts.org/bmctracker

    Any suggestions on what’s wrong and how to fix it gratefully received as I need to go live with a new map for 2019 in the next month.

    Thanks,

    Chris

    • This topic was modified 7 months, 1 week ago by  poolec.
    Attachments:
    You must be logged in to view attached files.
    #47512

    Perry
    Moderator

    Hi again Chris

    I hope this finds you well, sorry to hear this has come up.

    Can you please update to 7.11.03 (Pro and Basic), as we have recently ironed out a lot of issues.

    If you need us to manually apply the update we can do so, we would need you to open a ticket with your FTP details in order to do so, as it appears the details we have on file are no longer valid.

    Please let us know if that helps!

    Kind regards
    – Perry

    #47819

    poolec
    Member
    This reply has been marked as private.
    #47824

    Perry
    Moderator

    Hi Chris

    It appears that the REST API route at https://dev05.pinneypoole.net/wp-json/wpgmza/v1/datatables/ renders your web page – rather that the REST response we would expect here.

    The REST API has been present since WordPress 4.7, are you running 4.7 or later?

    Do you have any kind of security or URL rewriting software that would potentially affect these endpoints?

    I’m seeing the same thing if I visit this URL

    https://dev05.pinneypoole.net/wp-json/

    Where I would normally expect to see code describing the REST API.

    This appears to be a general issue with your WordPress installation – I suggest disabling all plugins (including our own) then visiting https://dev05.pinneypoole.net/wp-json/ . If the REST API is functioning correctly, you should see a screen full of code when you visit that URL. At the moment I see a page from your site.

    Please then start to re-enable plugins one by one, refreshing that page until you see anything other than code. That will help you establish which plugin is causing this. If that doesn’t help, it could be your theme, or possibly code in your .htaccess file re-writing the URL.

    Does that help?

    Kind regards
    – Perry

    #47879

    poolec
    Member

    Hi Perry,

    OK, most of that was way to technical for me, but I deactivated the plugins and then reactivated them one by one. It seems to be the Woocommerce plugin that is causing the problem on this installation.

    I created a copy of the live site and upgraded that to the current versions of WP Google Maps and it has worked fine. So there is clearly a corruption of some form on my Dev05 site, so I think it is time to reset it with a copy of the live site after I have noted the config changes I have been testing out.

    Thanks for the pointers,

    Chris

    PS Thought you might like to know that the data collected from the EBTS UK website using WP Google Maps last year is being used as part of a paper to be published tracking the spread of box tree moths across the UK.

    #47887

    Perry
    Moderator

    Hi Chris

    I’m glad you got to the bottom of it!

    That’s great to hear, I’ve shared that with the team! It’s a privilege, thank you 🙂

    Kind regards
    – Perry

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.