Marker library problem from Category screen

New home Forums Pro Add-on Troubleshooting Marker library problem from Category screen

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #52423
    mgreis
    Member

    I am not able to save a marker from the marker library when accessed from the Category screen (i.e. selecting a new marker for a Category).

    The \marker list opens as usual as does the individual marker screen (with the color wheel) once a marker is selected. But clicking the marker to save it produces no result. The marker screen stays displayed; the only way to exit is by clicking the close icon. On returning to the category screen, the marker is of course unchanged.

    I do notice one strange thing that may help in troubleshooting. When hovering over the new marker before clicking on it, the address displayed is something like this:

    Certificate

    After clicking on the marker to save (and getting no result), the address displayed looks like this:

    data:image/png;base64,iVBORw0KGgoAAAA….(long encoded string)

    This behavior does not occur when selecting the Marker Library from a individual marker’s page. Everything works as expected there.

    Thanks!

    #52424
    mgreis
    Member

    The first link rendered as “Certificate”. Text of link should read:

    www.mappity.org/marker_icons/certificate/?wpgmza-embed=1#

    #52460
    Perry
    Moderator

    Hi there

    Thank you for bringing this to our attention.

    We have reproduced the issue and are working on a fix at our end, this is due to an oversight following recent security changes.

    As a workaround, can you please try right clicking the link, copying the data:image/png link, opening a new tab, pasting the link in and then downloading the resulting image?

    Kind regards
    – Perry

    #52510
    mgreis
    Member

    Thanks, Perry.

    The workaround is spot on. It had occurred to me to download the image, but I figured that the arrangements for using the images in the plugin discouraged that practice. This is a great fix in the interim. Thanks!

    #52521
    Perry
    Moderator

    Hi there

    You’re very welcome!

    The patch which addresses this issue will go live today.

    Is there anything else we can help you with?

    Kind regards
    – Perry

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.