Marker Clusters Not Showing All The Included Options

New home Forums Gold Add-on Marker Clusters Not Showing All The Included Options

Tagged: 

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
    Posts
  • #78452
    briannabattles
    Participant

    You can see our map here: https://thepregnantandpostpartumathlete.com/professional-network/?swcfpc=1

    We are adding new markers to our map weekly and have hundreds. However, when we add new Markers with the same location it will show a cluster, for example “4” but when you zoom in and click on the cluster it ultimately only opens 1. This example is for searching Toronto, Canada.

    I’ve gone through several of the forums, cleared the caches, adjusted settings, updated the plugins etc. and am still not finding a solution to why we aren’t seeing all of the added markers. The name, in this same example, of a missing marker in Toronto is “Surabhi Veitch”.

    Any help would be greatly appreciated!

    #78466
    Matthew
    Moderator

    Hi there,

    Thank you for getting with us, we do appreciate your time.

    The feature that you would need is the ‘Near Vicinity Separation” feature whereby it allows you to separate markers that are in the same location.

    However, unfortunately this setting can not be used when the “Marker Clusters” feature is enabled, thus you may only use one or the other at this current stage.

    I hope this answers your question?

    Kindest Regards,
    Matthew

    #78508
    briannabattles
    Participant

    Hi Mark!

    Thanks for your response. Can you point me in the direction of documentation on how to remove the “Marker Clusters” and install the “Near Vicinity Separation” feature? I’m not finding anything relevant in order to do that.

    Thank you!

    Megan

    #78525
    Matthew
    Moderator

    Hi Megan,

    Thank you for your response and time on this, we do appreciate it!

    Unfortunately we do not have documentation for that, however, I am more than happy to provide you with the steps needed to do that thus please see below:

    Disable Marker Clusters
    1. Navigate to your Map Editor (Maps -> Edit).
    2. Click on the “Marker Clustering” tab.
    3. Set the “Enable Mass Marker Support” setting to “No.
    4. Click the “Save Map” button.

    Enable Near Vicinity Markers
    1. Navigate to Maps -> Settings -> Marker Separation.
    2. Set the “Enable Near-Vicinity Marker Control” setting to “Yes”.
    3. Click the “Save Settings” button.

    Once this has been done, the near vicinity markers feature should be enabled for your map.

    I hope this helps?

    Kindest Regards,
    Matthew

    #78541
    briannabattles
    Participant

    Hey Matthew,

    Ok, the removal for the Mass Marker Support worked — those clusters are gone.

    However, I’m still running into issues getting multiple markers to show in the same cities (i.e. the Toronto example from my original post). We currently have 643 markers, not sure if that has anything to do with it. Any other ideas?

    I’ve cleared the caches multiple times, tried resetting the near vicinity options as well.

    The only other thought I had was maybe the issue could lie with the “near-vicinity affected radius” being set to 1 meter. Our coaches often only give us the city they are located in, not their full address (hence the issue we’re encountering). Do you think this could be the problem?

    Help! 🙂

    I appreciate your help thus far!

    Megan

    #78577
    briannabattles
    Participant

    Hey there! Wanted to follow up on my last message from 9/20 — any ideas?

    Thanks so much!

    Megan

    #78586
    Matthew
    Moderator

    Hi Megan,

    Thank you for your time, and our apologies as we may have missed your response.

    I have taken a look at your map again and it appears that you are currently using an outdated version of the Pro Add-on (v8.0.34) whereas the current latest version is v9.0.24. We do not recommend using unmatched major versions between the basic and pro add-on as this may cause unexpected issues.

    Thus please may I start by asking if you would be open to upgrading the latest V9 pro add-on (https://www.wpgmaps.com/purchase-professional-version/) and confirm if this helps with the issue you are currently experiencing?

    If you are not yet ready to upgrade to the V9, please may I ask if you may at least update your Pro Add-on to the latest V8 version which is v8.1.22?

    I look forward to hearing back from you.

    Kindest Regards,
    Matthew

    #78593
    briannabattles
    Participant

    Hey Matthew,

    I removed the previous plugin for Pro and installed the new one I purchased. So far I’m not seeing any change. I’ve cleared the cache, double checked the settings from your previous message and still only showing one marker for Toronto, CA.

    I appreciate your help — thanks for answering all my questions and continuing to help!

    Megan

    #78606
    Matthew
    Moderator

    Hi Megan,

    Thank you for your response and time on this, it is much appreciated.

    Thank you for upgrading as this would definitely be beneficial in the long run as you would also be using the latest V9 version and thus should not experience any unexpected issues due to unmatched major versions.

    I have taken another look and please may I ask if you may set your “Affect Radius” setting for the Near vicinity markers to a value of 50 and confirm if this helps?

    I look forward to hearing back from you.

    Kindest Regards,
    Matthew

    #78611
    briannabattles
    Participant

    Hey Matthew!

    I updated the “Near-Vicinity Affected Radius” to 50 (Meters). Purged the cache and am not seeing any change. Any other ideas? Thank you!

    Attachments:
    You must be logged in to view attached files.
    #78650
    briannabattles
    Participant

    Checking in on this since it’s been a few days!

    #78685
    Matthew
    Moderator

    Hi there,

    Thank you for your patience and time on this, I really appreciate it!

    I have taken a look further and it appears that some of your markers may not have their lat/lng coordinates set correctly which is causing a JavaScript error. Some JavaScript errors may cause unexpected issues with proceeding scripts.

    Thus to attempt to remove this factor, please may I ask if you may edit your marker with the ID “2095”, and then resave it as it appears that this marker is causing the error as it’s lat/lng properties appear to be empty.

    Once this has been done, please do let me know so that I may test further?

    I look forward to hearing back from you.

    Kindest Regards,
    Matthew

    #78712
    briannabattles
    Participant

    Hey Matthew!

    That worked! Thank you so much. Will you take a look and double check that the error is clear on the back end?

    Thank you!!

    Megan

    #78713
    briannabattles
    Participant

    One quick question – the clusters are now showing up as a red pin, is there a way to adjust the appearance of the pin or change the color?

    Megan

    #78732
    Matthew
    Moderator

    Hi Megan,

    Thank you for your response and I am glad to hear that it works now after editing the respective marker.

    With regards to your new question, yes you may change the cluster placeholder icon in the settings area (Maps -> Settings -> Marker Separation).

    Please let me know if this helps?

    Kindest Regards,
    Matthew

Viewing 15 posts - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.