Marker Category

This topic contains 10 replies, has 2 voices, and was last updated by  msuckel 2 months, 1 week ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #53555

    msuckel
    Member

    Is it possible on the VGM form to remove the ‘all’ in the category choice? If they leave it as ‘all, the category doesn’t even save the category at all. If they chose one or the the other it works fine.

    See this form.

    ‘http://pumpkinfest.com/2019-decorating-contest-entry-form/

    Thanks,
    Matt

    #53556

    Dylan
    Moderator

    Hi Matt,

    Thank you for getting in touch, we do appreciate your time.

    Unfortunately, we do not have a setting available currently to achieve this. However, this is achievable with a bit of custom JavaScript code.

    Please find the custom JavaScript to achieve this below:

    jQuery(window).load(function(){
    jQuery(‘.wpgmaps_user_form #wpgmza_category option:first-child’).remove();
    });

    This can be added under Maps -> Settings -> Advanced -> Custom JavaScript.

    I hope this helps?

    Kind Regards,
    Dylan Auty

    #53566

    msuckel
    Member

    Didn’t seem to work?

    #53581

    Dylan
    Moderator

    Hi there,

    My sincerest apologies, it appears this may be due to the fact that the form is separate from the map, which means the JavaScript may not run on this page.

    Would you be open to moving this JavaScript to a 3rd party custom JavaScript plugin such as Simple Custom CSS and JS found here: https://wordpress.org/plugins/custom-css-js/

    This should allow the script to run on the form page as well, which should remove the option mentioned.

    I look forward to hearing back from you.

    Kind Regards,
    Dylan Auty

    #53821

    msuckel
    Member

    still having issues here, are we sure it is the form you listed and not the wpgmaps_ugm_user_form or something?

    #53831

    Dylan
    Moderator

    Hi there,

    Thank you for getting back to me, I do appreciate your time.

    Could I ask you to confirm that you have installed the 3rd party plugin I recommended and moved the JavaScript to the new plugin instead?

    I had a look at your website and the script I provided you with is not currently loading on the page, which means it would not remove the option as intended.

    I would also be happy to handle this process on your behalf if you prefer?

    Kind Regards,
    Dylan Auty

    #53849

    msuckel
    Member
    This reply has been marked as private.
    #53850

    Dylan
    Moderator
    This reply has been marked as private.
    #53852

    msuckel
    Member
    This reply has been marked as private.
    #53873

    Dylan
    Moderator

    Hi Matt,

    Thank you for getting back to me.

    I believe this should now be working as intended, please take a look and confirm?

    It appears the formatting was mutated by our forum ‘code block’. I have re-written this and it appears to be working as intended.

    I look forward to hearing back from you.

    Kind Regards,
    Dylan Auty

    #53887

    msuckel
    Member
    This reply has been marked as private.
    #53910

    Dylan
    Moderator

    Hi Matt,

    Only a pleasure, always happy to help.

    I look forward to hearing back from you at that stage.

    🙂

    Kind Regards,
    Dylan Auty

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.