Maps not displaying on FIrefox, IE & Safari!

New home Forums Pro Add-on Troubleshooting Maps not displaying on FIrefox, IE & Safari!

This topic contains 4 replies, has 2 voices, and was last updated by  mgreis 1 month, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #53014

    mgreis
    Member

    Need some help urgently! I’ve just discovered that my first map – replacing a Google Fusion tables map – is not showing up on Firefox, IE or Safari. Chrome is fine.

    I thought I had tested it on Safari and Firefox during the couple of weeks I was working with you to replicate my Fusion Tables map, but now I don’t know what to think.

    The other forum posts I found on this topic are many years old, so they are of no help. This site is live, so I don’t have the luxury of changing the theme to test it. (I am using a child theme for Spacious, from ThemeGrill, which is pretty widely used, though.)

    Here’s a link to the map:

    Where’s Solar – Map of Needham Solar Installations and Solar Ambassadors

    Running WP 4.9.10
    Spacious 1.6.5
    wpgpmaps 7.11.44

    Thanks!

    #53019

    Perry
    Moderator

    Hi Michael

    Perry here again, sorry to hear this.

    I visited the page you linked us to and I can see a JavaScript error originating from this file:

    https://www.greenneedham.org/blog/wp-content/themes/spacious/js/navigation.js?ver=4.9.10

    This is part of your “Spacious” theme. An error happens during jQuery’s “ready” phase, and execution halts. This means that the “ready” event doesn’t fire for our plugin, so the map is never initialised.

    If we use live source edit to cause this particular function not to run, then the map works as expected. Please see here https://pasteboard.co/IrHjSQLs.png

    You could potentially disable that by adding

    return;

    on line 134 of the file throwing this error, however please be aware that this will probably break the functionality of your theme and may lead to unexpected results.

    You would need to reach out to the theme author for a concrete fix on this.

    I hope that helps?

    Kind regards
    – Perry

    #53035

    mgreis
    Member

    Thanks, Perry.

    I created an item on the Spacious Theme support forum on wordpress.org with the information you provided.

    Let’s see what they come back with.

    #53039

    Perry
    Moderator

    Hi Michael

    That’s great, thank you. Please do let us know what the outcome is.

    Kind regards
    – Perry

    #53074

    mgreis
    Member

    Hi Perry,

    Looks like I’m back in business. Somewhere along the line, ThemeGrill made changes to the header.php file. I just needed to recreate the header.php in my child theme from the current version of the header.php in the parent theme.

    I’ve checked it in Firefox, Safari, IE and even Edge. All looks good.

    Thanks!

    #53090

    Perry
    Moderator

    Hi Michael

    You’re most welcome!

    If you need anything else, please don’t hesitate to get in touch.

    Kind regards
    – Perry

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.