Map Not Showing on Front End

New home Forums Basic Version Troubleshooting Map Not Showing on Front End

Tagged: 

  • This topic has 10 replies, 3 voices, and was last updated 5 years ago by Dylan.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #23144
    buxjr
    Member

    Howdy,

    Just setup a new WP site, using the “bateaux” theme (which includes the basic version of WPGM). In the dashboard, the map I configured displays just fine. But, on the contact page, it’s just a blank space. I’ve looked at the javascript error console and it reveals a script error, “‘google’ is undefined”.

    Can anyone steer me in the correct direction? Any and all advice is greatly appreciated.

    Here is the contact page:
    http://tesoridigitalmarketing.com/contact

    Thanks in advance.

    • This topic was modified 5 years, 11 months ago by buxjr.
    • This topic was modified 5 years, 11 months ago by buxjr.
    #23163
    Dylan
    Moderator

    Hi there,

    Thank you so much for taking a moment to get in touch, we really appreciate it.

    I had a look at your site and it appears that the Google Maps API is not loading on the page, preventing the map from displaying as intended.

    Could I ask you to go to Maps -> Settings -> And ensure you have not enabled the setting labelled ‘Do not load the Google Maps API’ as this will prevent the API from loading as intended?

    #23169
    buxjr
    Member

    Hey Dylan,

    Thanks for getting back to me.

    Yes, in my many attempts to get this plugin working, I did in fact have that setting checked, as it was not working in the first place.

    I have unchecked that feature, as per your request. Alas, to no avail. Can you please take another look and let me know where to go from here?

    Thanks in advance.

    #23170
    Dylan
    Moderator

    Hi again,

    Thank you so much for your time on this one.

    I had a look again and it appears that the reference to the google maps API url is being altered.

    Could I ask if you make use of any JavaScript optimization plugins? We often see plugins like this alter JavaScript file locations in attempt to host them locally.

    #23179
    buxjr
    Member

    Hey Again Dylan,

    No, not using any JavaScript optimization plugins. However, when you mentioned the URL being incorrect it got me thinking…

    The theme we purchased does include the “Root Relative URLs” plugin. So, on a whim I disabled that plugin. Low and behold, the map started working instantly. So that was clearly the culprit.

    Not sure if we even needed that particular plugin in the first place. So we’ll leave it disabled for now. But maybe compatibility with that plugin is something you can address in future updates? That is a relatively common plugin included with commercial themes.

    Thanks again for your help.

    #23184
    Andrew
    Member

    Thank you for your feedback.

    I have notified our development team about the clash between “Root Relative URLs” plugin and they will definitely created a fix for it.

    Glad to hear it’s working as expected now. 🙂

    Please do not hesitate to open a new support thread should you require any further assistance.

    #31659
    buxjr
    Member

    Hey Guys,

    Resurrecting this thread as I am experiencing a similar issue again, on a new site, but one that is still utilizing the Bateaux theme. However, in this case, I am completely unable to disable “Root Relative Urls” — as soon as I do, this theme takes a major dump! Wondering if y’all ever got the conflict between that Root Relative Urls plugin and your maps plugin resolved. Here is where the page is located:

    http://dev.deerparkstairs.com.php7-27.phx1-1.websitetestlink.com/contact-us/

    The map is also NOT showing in the admin either. Clearly there is some kind of javascript error, but I can’t seem to resolve it. Any help or advice you can offer is greatly appreciated. Thanks, in advance.

    #31755
    Dylan
    Moderator

    Hi there,

    Thank you so much for getting in touch and reporting your issue.

    I would really like to get this resolved as soon as possible for you. 🙂

    I had a look at your site and I found that the Google Maps API may not be including correctly on the page.

    Could I ask you to send me a screenshot of your Maps -> Settings area so that I can confirm if the setup is correct?

    #32055
    buxjr
    Member

    Dylan,

    Thanks for getting back to me. Sure, attached please find a screen capture of the WP-Maps settings page. Just an FYI — I have another WP site (also Bateaux theme) that is experiencing this identical issue. Clearly, this is an incompatibility between the “Root Relative URLs” plugin and WP Maps. Problem is, within the Bateaux theme, you CANNOT deactive RRURLS. The entire theme falls apart it you do. So, sadly, this is not an option.

    Please advise. Thanks.

    Attachments:
    You must be logged in to view attached files.
    #32058
    buxjr
    Member

    The plugin is NOT working correctly within the Dashboard either. View attached screen shot.

    Attachments:
    You must be logged in to view attached files.
    #32104
    Dylan
    Moderator

    Hi there,

    So sorry for the delay in response, I was out of the office attending a WordPress conference last week and could not get back to you as soon as I would have liked to.

    Could I ask that you open an official support ticket with us here: http://www.wpgmaps.com/contact-us/

    You will see some check boxes which you need to check before sending a support request.

    This would allow our team to work through this potential conflict with you in a more direct environment.

    If this is indeed a conflict, we would of course like to patch this ASAP and get an update released for it.

    Thank you for your time. 🙂

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.