Making external Links nofollow

New home Forums Pro Add-on Making external Links nofollow

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #66491
    MKAff
    Participant

    Hey,
    thanks for the awesome plugin!

    I’ve just got a quick question: How to mark external Links in the table below the embedded map as nofollow.

    So far, we’ve used this trick here (https://www.wpgmaps.com/forums/topic/making-the-link-inside-the-info-balloon-nofollow/). With 8.1. you’ve apparently restructured your code. What’s the 8.1. solution for this or – even better – could you implement this option in one of your upcoming updates?

    Keep up the great work & best regards,
    Max

    #66493
    Steven
    Moderator

    Hi there,

    Thank you so much for getting in touch, we really appreciate your time.

    Unfortuantely, this is a very specific scenario, so changing this will affect every WP Google Maps user’s website.

    We have adjusted the core code of WP Google Maps to function differently so I took a quick look at the core code and I believe a simple adjustment might help with this.

    Could I kindly ask you to navigate to the wp-google-maps-pro/js/v8/pro-info-window.js file and adjust the line “283”
    From:
    var a = $(“”);

    To:
    var a = $(“”);

    Kindly let me know if this perhaps works for you?

    Kindest Regards,
    Steven De Beer

    #66529
    MKAff
    Participant

    Hey,
    thanks for your reply!

    I think, you meant adding rel=’nofollow’ to this code line:

    var a = $(““) -> var a = $(““);

    Unfortunately, this didn’t quite do the job.

    I also tried adding this line

    a.attr(“ref”,”nofollow”)

    below, but it also did’nt work.

    Do you have any other hints?

    Thanks in advance!

    #66540
    Steven
    Moderator

    Hi there,

    Thank you so much for getting back to me.

    My sincerest apologies for the inconvenience, I am not quite sure what occurred with my copy paste there.

    Kindly see the screenshot attached simply for reference.

    You will need to enable and disable the Developer mode via Maps -> Settings -> Advanced as this will allow the scripts to recompile.

    Kindest Regards,
    Steven De Beer

    • This reply was modified 8 months, 1 week ago by Steven.
    Attachments:
    You must be logged in to view attached files.
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.