Maker Listings – Column Settings

New home Forums Pro Add-on Maker Listings – Column Settings

Viewing 15 posts - 16 through 30 (of 40 total)
  • Author
    Posts
  • #58845
    AbelC
    Moderator

    Hi There,

    Thank you so much for letting me know, and my apologies for the mistake on my behalf.

    Could I kindly ask if you could please replace the previous code with the following custom JS code below:

    jQuery(function($) {
    $(window).on("markersplaced.wpgmza", function(event) {
     $('.wpgmza_table_link a').text('MEHR ERFAHREN');
    $('.wpgmza_table_link a').attr("target", "");
    });
    });

    If this issue persists, would you perhaps be open to please submit a support ticket here -> https://www.wpgmaps.com/support/ -> Please provide us with a temporary admin account so that we can take a closer look at what is causing this issue?

    Could you also then please mention my name in this ticket so that the other agents will assign the ticket to me?

    I look forward to hearing back from you.

    Kind Regards,
    Abel

    #58851
    danbnb
    Participant
    This reply has been marked as private.
    #58863
    AbelC
    Moderator

    Hi Daniel,

    Thank you so much for letting me know, and not a problem at all.

    We look forward to hearing back from you and assisting you further.

    In the meantime, would you perhaps be open to please install a 3rd party plugin to add your custom JS code to see if this resolves the issue you are currently experiencing?

    We recommend using Simple Custom CSS and JS – https://wordpress.org/plugins/custom-css-js/

    Once you have installed the 3rd party plugin, could you please add the Custom JS code in the Custom JS box?

    Please do let me know if this resolves the issue you are currently experiencing?

    Kind Regards,
    Abel

    #58866
    danbnb
    Participant

    Hi again Abel,

    i’ve tested you script with “Simple Custom CSS and JS” but has no effect. The plugin itself says:

    “If you are using the jQuery library, then don’t forget to wrap your code inside jQuery.ready() as follows:

    jQuery(document).ready(function( $ ){
    // Your code in here
    });

    I did this and put your code inside of it, didn’t work. I also tested your code only, didn’t work πŸ™

    I have installed WP Google Maps on a staging environment and added an admin accout for you, i will share the login details in the next posting. I am sorry that my wordpress is in German, i hope you will understand the menues. Feel free to test everything you want there.

    Thank you so very much for your help!!!

    #58871
    danbnb
    Participant

    hmm the posting with the login data i provided is disappeared, did you remove it?

    #58874
    danbnb
    Participant
    This reply has been marked as private.
    #58875
    danbnb
    Participant

    Ok i think private postings are not working, if there are too much URLs in it, right? Now you should see it.

    You will find the custom-css under design/theme-editor (i am using a child theme)
    You will the the custom-js in the β€œSimple Custom CSS and JS” plugin.

    • This reply was modified 6 months, 1 week ago by danbnb.
    • This reply was modified 6 months, 1 week ago by danbnb.
    • This reply was modified 6 months, 1 week ago by danbnb.
    #58885
    AbelC
    Moderator

    Hi There,

    Thank you so much for your time on this one, we do appreciate it.

    We have now received the login details.

    Could I kindly ask if you please confirm the login URL to the staging environment?

    We will then be able to log in and take a closer look at what is causing this issue.

    In the meantime, we have now made a couple of changes to the code.

    Could you please replace the previous code with the following Custom JS below:

    jQuery(window).load(function(){
    	 jQuery('body').find('.wpgmza_table_link a').text('MEHR ERFAHREN');
    jQuery('body').find('.wpgmza_table_link a').attr("target", "");
    	var dataTable = jQuery('body').find('.wpgmza_table').DataTable();
    dataTable.on('draw', function(){
    console.log('TEST');
     jQuery('body').find('.wpgmza_table_link a').text('MEHR ERFAHREN');
    jQuery('body').find('.wpgmza_table_link a').attr("target", "");
    });	
    });

    Again, we do apologize for the back and forth on this one.

    I look forward to hearing back from you.

    Kind Regards,
    Abel

    #58891
    danbnb
    Participant

    ah sorry, yeah there is a custom URL for Login.

    But your code finally works!!! πŸ™‚

    So you won’t need to login anymore right?

    BIG THANKS TO YOU!!!

    • This reply was modified 6 months, 1 week ago by danbnb.
    #58899
    AbelC
    Moderator

    Hi There,

    Thank you so much for letting me know, and that is great to hear.

    No, we do not require access anymore.

    It is only a pleasure and please do let me know if there is ever anything else that I can assist you with.

    Have a great day!

    Kind Regards,
    Abel

    • This reply was modified 6 months, 1 week ago by AbelC.
    #58909
    danbnb
    Participant

    damn, it suddenly stopped working, even worse it shows no marker listing anylonger and says: “No data available in table”. Please see screenshot attached.

    Your Account in the staging environment is still active, i will you give you the full login data in the next post, feel free to test. At the Moment your JS Code is in Maps (German: Karten) -> Settings (German: Einstellungen) -> Advanced (German: Erweitert)-> Custom JS.

    thank you very much, this problem should really annoy you by now πŸ˜‰

    • This reply was modified 6 months, 1 week ago by danbnb.
    #58910
    danbnb
    Participant
    This reply has been marked as private.
    #58912
    danbnb
    Participant

    here is the screenshot sorry πŸ™‚

    Attachments:
    You must be logged in to view attached files.
    #58920
    AbelC
    Moderator
    This reply has been marked as private.
    #58932
    danbnb
    Participant
    This reply has been marked as private.
Viewing 15 posts - 16 through 30 (of 40 total)
  • You must be logged in to reply to this topic.