Maker Listings – Column Settings

New home Forums Pro Add-on Maker Listings – Column Settings

Viewing 15 posts - 1 through 15 (of 40 total)
  • Author
    Posts
  • #58396
    danbnb
    Participant

    Hello support,

    i want different marker listing Column Settings for different devices. For this I could use a duplicated map for mobile, but for example i would not need the “Icon Column” and the “Description Column” in the Marker Listing for this map. In the WP Google Maps Settings (shown on the screenshot) there is a global setting for this, but is there a way to apply some of these settigns just to a specific map or marker listing? Even better would be a solution with hiding those colums via media querys, so i dont have to use a duplicated map for mobile.

    • This topic was modified 7 months, 1 week ago by danbnb.
    Attachments:
    You must be logged in to view attached files.
    #58408
    AbelC
    Moderator

    Hi There,

    Thank you so much for getting in touch with us.

    Unfortunately, this is not supported by default at the moment, however, this can be achieved with Custom CSS. We do apologize for the inconvenience.

    Could I kindly ask if you could please provide me with a link to your map page so that we can provide you with the CSS needed to achieve this?

    I hope this helps clarify, and we look forward to hearing back from you.

    Kind Regards,
    Abel

    #58611
    danbnb
    Participant
    This reply has been marked as private.
    #58627
    AbelC
    Moderator

    Hi There,

    Thank you so much for getting back to me.

    Could I kindly ask if you could please navigate to Maps -> Settings -> Advanced -> Custom CSS -> Please paste the following code below:

    @media only screen and (max-width: 600px) {
      .wpgmza_table_address {    
        display: none;
      }
      .wpgmza_table_marker {    
        display: none;
      }
      [data-dtr-index="3"] {    
        display: none;
      }
      [data-dtr-index="0"] {    
        display: none;
      }
    }

    This should now hide the address and icon column on mobile devices.

    Please do let me know if this is working for you?

    I look forward to hearing back from you.

    Kind Regards,
    Abel

    #58640
    danbnb
    Participant

    Hi Abel,

    that works fine. I do understand the classes .wpgmza_table_address and .wpgmza_table_marker and that you hide them by the command “display:none”, but can you please explain to me, what [data-dtr-index=”3″] and [data-dtr-index=”0″] is or does?

    #58641
    danbnb
    Participant

    i forgot to say: Thank you very much 🙂

    #58655
    AbelC
    Moderator

    Hi There,

    That is great to hear, and not a problem at all.

    The Advanced table marker listing will create these selectors on mobile devices.

    Each selector will be unique. We have then added the command “display:none” to these selectors which will hide the address and icon field.

    I hope this helps clarify, and please do let me know if there is anything else that we can assist you with.

    Kind Regards,
    Abel

    #58714
    danbnb
    Participant

    Hello Abel,

    thanks for your information. Yes, there is more you cpuld me help with. If you load the site url I prvovided on mobile, you will see, that the map focus is not optimal. so my questionis: can I set another focus point and/or choose another zoom level on mobile devices somehow?

    kind regards,
    Daniel

    #58727
    AbelC
    Moderator

    Hi Daniel,

    Thank you so much for getting back to me, and our sincere apologies for the inconvenience.

    Unfortunately, this is not supported by default at the moment.

    However, we recommend enabling the “Fit map bounds to markers” in Maps -> Edit -> Advanced Settings -> Scroll down to “Fit map bounds to markers” -> Please enable this option.

    This will now adjust the zoom level to display all the markers on your map.

    I hope this helps clarify, and please do let me know if this is working for you.

    Kind Regards,
    Abel

    #58744
    danbnb
    Participant

    Hello Abel,

    me again 🙂

    i wanted to only show the markers and the title and hided the green “+” icon too with this code:

      .wpgmza_table_address {    
        display: none;
      }
      .wpgmza_table_category {    
        display: none;
      }
    	
      [data-dtr-index="4"] {    
        display: none;
      }	
      [data-dtr-index="3"] {    
        display: none;
      }
      [data-dtr-index="2"] {    
        display: none;
      }	
      [data-dtr-index="0"] {    
        display: none;
      }
    
    table.dataTable.dtr-inline.collapsed tbody td:first-child::before, table.dataTable.dtr-inline.collapsed tbody th:first-child::before {
    	display:none !important;
    	}	

    As you can see, in the mobile view i need no additional information to show, so i hided data-dtr-index 0 to 4. Now my 1st question is, can i disable the clickable field on the marker completely? 2nd question: What i really don’t like is the broken line at every second row (see my screenshot), how can that be fixed?

    P.S: Thanks for your tipp with “Fit map bounds to markers”, it works like a charm 🙂

    • This reply was modified 6 months, 2 weeks ago by danbnb.
    Attachments:
    You must be logged in to view attached files.
    #58770
    AbelC
    Moderator

    Hi There,

    Thank you so much for getting back to me, and my sincere apologies for the delayed response.

    Please find my response below:

    1. You can hide the blank field by adding the following Custom CSS below:

    @media only screen and (max-width: 600px) {
      .responsive.wpgmza_table .child {    
        display: none;
      }
    }

    If this issue persists, could you please provide me with a screenshot of the issue you are currently experiencing?

    2. Unfortunately, I was unable to replicate this issue.

    Could you please confirm if you are still experiencing this issue?

    If so, could you please confirm the browser and device you are using?

    We will then be able to try and replicate this issue.

    We look forward to hearing back from you.

    Kind Regards,
    Abel

    #58831
    danbnb
    Participant

    thanks for your help with the 1st question.

    2nd question is done, it’s only an issue in the firefox mobile preview (Strg-Shift-M), on a real smartphone you can’t see the “broken lines”.

    • This reply was modified 6 months, 1 week ago by danbnb.
    • This reply was modified 6 months, 1 week ago by danbnb.
    #58834
    danbnb
    Participant

    i have a new question for you, i am sorry 😉

    As you can see in the marker Listing, there is “MORE DETAILS” in the “Link” Column.

    1) I have translated “MORE DETAILS” in to German in the wp-google-maps-de_DE.po to “MEHR ERFAHREN”. That hat worked fine, but after every WP Google Maps Update i have to do this again. This is quite annoying, because nearly every week there is an update. Is there maybe another solution you can help me with?

    2) If you click on the “MORE DETAILS” Link it opens in a new window. Is it possible to open these links in the same/actual window?

    #58836
    AbelC
    Moderator

    Hi There,

    Thank you so much for your response.

    Please find my response below:

    1. Unfortunately, we do not recommend you to change the core files as the changes will be lost when you update the plugin.

    We recommend using Custom JS to change these text.

    Could I kindly ask if you could please add the following Custom JS code below:

    jQuery(function($){
     $('.wpgmza_table_link a').text('MEHR ERFAHREN');
    $('.wpgmza_table_link a').attr("target", "");
    });

    2. Unfortunately, this is not supported by default at the moment, however, I have added code to achieve this in the Custom JS code provided in 1.

    With that said, we have added this option to WP Google Maps 8.1.

    I hope this helps clarify, and please do let me know if this is working for you.

    Kind Regards,
    Abel

    #58837
    danbnb
    Participant

    Hi There,

    Thank you for your fast response.

    Unfornately the code you provided has no effect or i pasted it in the wrong spot. I pasted it under Maps -> Settings -> Advanced -> Custom JS… see screenshot please.

    Best regards,
    Daniel

    Attachments:
    You must be logged in to view attached files.
Viewing 15 posts - 1 through 15 (of 40 total)
  • You must be logged in to reply to this topic.