Infowindow format sometimes changes

New home Forums Pro Add-on Infowindow format sometimes changes

Tagged: 

  • This topic has 5 replies, 2 voices, and was last updated 2 years ago by Steven.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #72942
    funkypancake
    Participant

    hi

    loving the plugin, but i’m struggling with my Infowindows.

    I have four issues:

    1) When i go to a location initially the title is placed over the description. However, if i click on a few different markers and move the map around a bit, it eventually comes in looking ok. Weird! And also frustrating as it means the description/information is missing.

    2) If the text in the description runs to multiple lines there is a line space between the lines which i haven’t added. It makes it tricky to read. i’d rather it was just one text block.

    3) Sometimes the text appears description text appears over the image. I think that’s related to point 1 above, as it doesn’t alway happen

    4) I’d like to change the fonts for the title, description and ‘website’ link so they are all the same. Font size is ok

    I’m using OpenLayers and Default Infowindows with image width set to always resize to 200 and Max infoWindow Width to 200.

    website address is http://www.fromthepit.co.nz/visit

    Thanks in advance

    Dave

    Attachments:
    You must be logged in to view attached files.
    #72953
    Steven
    Moderator

    Hi there,

    Thank you so much for getting in touch, we really appreciate your time.

    Kindly find my responses below:
    1. The info window style chosen here, is to display the title over the image with a slight transparency and so is intended. Currently, there are some markers with descriptions and others without so kindly ensure these markers with no description do have a description added and if so, that the website cache has been cleared.

    If you would like to adjust the style for the Title element so that it no longer appears above the image, kindly apply the following CSS via Maps -> Settings -> Advanced Settings -> Custom CSS:

    .wpgmza_iw_title {
    float: unset !important;
    position: relative !important;
    }

    2. This can be adjusted with some custom CSS in tweaking the line-height:

    .wpgmza_iw_description {
    line-height: 15px !important;
    }

    3. This is correct and is specifically with the title text which the CSS above should help with if you do no desire this style.

    4. To adjust the font family, you can use the following CSS:

    #wpgmza_iw_holder_1 {
    font-style: italic;
    }

    Kindly do note, however, you are currently using the modern info window and not the default info window as the default info window is the more traditional Google Styled info window, and the Modern Info window currently being used is a more custom info window.

    I hope this helps?

    Kindest Regards,
    Steven De Beer

    #72960
    funkypancake
    Participant

    Thank you for your prompt reply.

    I have now changed the map back to the default info window, and things look better. I’ve added descriptions for all entries too to keep it tidy.

    However, the css to change the line height for the description doesn’t seem to work.

    i’ve tried the following but i can’t see a difference:

    .wpgmza_iw_description {
    line-height: 10px !important;
    }

    #72965
    Steven
    Moderator

    Hi again,

    The classes and ids across the different info windows are different, so please use the following CSS to target the description line-height for the default info windows:

    .wpgmza_infowindow_description {
    line-height: 16px !important;
    }

    Once added, let me know if this helps?

    Kindest Regards,
    Steven De Beer

    #72966
    funkypancake
    Participant

    Thanks so much. That worked perfectly 20px gave me what i was after. I really appreciate your speedy responses and your fantastic plugin! I shall leave a review on the plugin page right away!

    #72973
    Steven
    Moderator

    Hi @funkypancake,

    Thank you so much for getting back to me.

    I am so glad this has helped and thank you so much for the kind words.

    Do let us know if you have any other issues or questions as we are always eager to assist.

    Have a fantastic week further!

    Kindest Regards,
    Steven De Beer

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.