I want vistor generated markers on a seperate page

New home Forums Visitor Generated Markers I want vistor generated markers on a seperate page

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #60847
    ReliableHelp
    Participant

    Hi, I have purchased the visitor generator markers add on. I want to seperate the VGM form from the maps. For instance I set that only registered users can create VGM but I don’t want all registered users to be able to do this, only the ones that meet a certain criteria.

    How would I go about this?

    #60852

    Hi there,

    Thanks so much for getting in touch.

    This can be done as mentioned in the following documentation:
    https://www.wpgmaps.com/documentation/separating-the-vgm-form-from-the-map/

    Essentially, you can use the following shortcode to display the form, separated from the map:
    [wpgmza_vgm_form link_to_map="Map ID" redirect_to="Page Link"]

    You can set the link_to_map to the map ID and the redirect_to, to the link that it should be redirected to if it is successfully created – and is normally a link to the map page to view the newly added marker.

    When adding the map to the page, you can also add ‘disable_vgm_form=”1″‘ to the shortcode to disable the VGM form there, for example:
    [wpgmza id="1" disable_vgm_form="1"]

    I hope this helps and please let me know if you have any questions and I will be more than happy to help.

    Thanks for your time.

    Best regards,
    Dylan

    #66574
    Jaroslaw Smolar
    Participant

    Hello,

    first – apologize – english isn’t “my” language

    so in short my problem is – when I put shortcodes –
    [wpgmza_vgm_form link_to_map="1"] OR
    [wpgmza_vgm_form link_to_map="1" redirect_to="https://blablablabla.bla/?page_id=6056"]
    isn’t working
    but if I put this shortcode in one page with a map [wpgmza id="1"] – for eg in second column – form work perfect 🙂
    without map on the same page – nothing 🙁
    tried put map on the same page and then hide it – nope 🙁
    also tried “first repair step in cosmos = reboot” 😉 – deleted page and make new fresh one – nope 🙁
    Help me Obi…. U R my only hope 😉

    Best Regards
    Jaroslaw

    • This reply was modified 2 weeks ago by Jaroslaw Smolar.
    #66680
    Steven
    Moderator

    Hi there,

    Thank you so much for getting in touch, we really appreciate your time.

    Could I kindly ask you to kindly clarify what is not working?

    When adding the shortcode with the link to map parameters, is the form not being added, or is the form being added but you are not able to add a marker?

    I look forward to hearing back from you.

    Kindest Regards,
    Steven De Beer

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.