Help with Pages not loading correctly

New home Forums Pro Add-on Troubleshooting Help with Pages not loading correctly

This topic contains 2 replies, has 2 voices, and was last updated by  cletch 5 months, 4 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #50376

    cletch
    Member

    Front and back end I am getting an error “This page didn’t load Google Maps correctly. See the JavaScript console for technical details.” The console says:
    1) You have included the Google Maps JavaScript API multiple times on this page. This may cause unexpected errors.
    2) Google Maps JavaScript API error: RefererNotAllowedMapError
    3) Google Maps JavaScript API warning: RetiredVersion

    RE #1 – is this because she has 2 google accounts requesting a key for this site? Obviously there is only 1 key used in the plugin.

    Initially, this was set up, the client had to change her credit card, got confused about Google accounts and added a credit card in a different account – she can’t remember how to get into the first one. She followed the “start here” and so when I tried to help, the process looks different than your steps. I have a key set up. I have enabled the Directions API, Maps Embed API, Javascript API, and made key restrictions for *.tahoe4sale.com/* and *tahoe4sale.com/* according to your instructions. It still doesn’t work. What am I missing? Thank you in advance!

    #50381

    Perry
    Moderator

    Hi there

    Thank you for getting in touch, sorry to hear you are experiencing issues.

    Regarding point 1), yes, that will be the cause. You can try our setting “Prevent other plugins and theme loading Maps API” in Maps -> Settings. You could also try preventing our plugin from loading the Maps API using the settings there, please be aware that if you do so, the key you have entered into our plugin will not be used, you’ll need to find out the other API source and add your key there if that is the key you wish to use.

    Alternatively, if you are able to provide access to the site, we can establish the source of the other API load and advise on how to manually remove that.

    2) Please remove *.tahoe4sale.com/* leaving only *tahoe4sale.com/*

    The first should not be used – if you have seen otherwise in our documentation, we would very much appreciate a link to that page so we can get that corrected.

    3) Which version of the plugin and Pro add-on are you running, please?

    Kind regards
    – Perry

    #50403

    cletch
    Member

    Thanks, Perry.

    1) I must be blind… can’t find this setting?
    2) Done. Yes, it was in your documentation but I went round and round following links for an hour or more so not sure where I saw it – sorry! I will happily give you access to the website – let me know how to do so privately.
    3) The pro addon is Version 5.77 and WP maps version is 7.11.25

    #50425

    Perry
    Moderator

    Hi there

    Sorry to have taken up your time with this, that setting is only available in Pro 7 and above,

    Can you please open a ticket at https://wpgmaps.com/contact-us for the attention of Perry, please reference this thread and we’ll get this solved for you as soon as possible.

    Thank you for your patience in this matter!

    Kind regards
    – Perry

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.