Grey Map But Has Marker

New home Forums Basic Version Grey Map But Has Marker

Tagged: 

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #30899
    bculbertson
    Member

    Have Basic Version. First map I’ve used. Created API, and API is showing that I’m calling it.

    When load the page, the map has no streets on it (grey), has my marker. The zoom buttons also look distorted and weird.

    I don’t have any errors, but I do have a Retired Version warning.
    See attached images

    Attachments:
    You must be logged in to view attached files.
    #30942

    Hi there,

    Thank you so much for getting in touch with us!

    I am really sorry for the delay in response and for the difficulties you are having.

    This is most likely a styling issue that is being caused by your theme or another plugin.

    Could I kindly ask for a link to the website so that I can debug this further and find a solution for you as soon as possible?

    Kind regards,
    Dylan

    #30953
    bculbertson
    Member
    #30966

    Hi there,

    Thanks for the link.

    Can you please add the following CSS to ‘Maps’ -> ‘Settings’ -> ‘Advanced Settings’:
    #wpgmza_map img {
    max-width: 255.5px !important;
    width: 255.5px !important;
    max-height: !important;
    height: !important;
    }

    Please save the settings, clear the cache and test it again.

    Please let me know if this helps.

    Thank you for your time.

    Kind regards,
    Dylan

    #30967

    Hi there,

    My apologies, it seems like the code wasn’t copied correctly.

    Please add the following CSS and let me know if it helps:

    max-width: 255.5px !important;
    width: 255.5px !important;
    max-height: 255.5px !important;
    height: 255.5px !important;

    Thanks.

    Kind regards,
    Dylan

    #30974
    bculbertson
    Member

    I tried the css (both that you included) and neither worked.

    Attached is image of what I have in the settings

    Attachments:
    You must be logged in to view attached files.
    #31040

    Hi Paul,

    My sincere apologies for the delay in response and for the confusion.

    Could you please replace it with the following:
    #wpgmza_map img {
    max-width: 255.5px !important;
    width: 255.5px !important;
    max-height: 255.5px !important;
    height: 255.5px !important;
    }

    This should fix it.

    Please let me know.

    Kind regards,
    Dylan

    #31053
    bculbertson
    Member

    Unfortunately, this didn’t work.

    Changing my theme to the WP standard theme showed that the map correctly works there.

    My theme is Illdy (made a child theme of it, but no custom setting on there yet.).

    Please advise. Thank you,
    Bobby

    #31058

    Hi Bobby,

    I am sorry to hear that didn’t work.

    Would you perhaps be open to creating a temporary admin account for me so that I can debug and fix this for you ASAP?

    Kind regards,
    Dylan

    #31070
    bculbertson
    Member

    You can cancel the investigation — I decided to just embed the iframe of the Google Map

    #31073

    Hi Bobby,

    Thanks for letting me know. I am really sorry for the trouble and that you had to go with the iframe instead.

    Have a great day further and please let me know if there is anything else I can help you with.

    Kind regards,
    Dylan

    #32157
    winnewoerp
    Member

    Hi there,

    We have the same problem with the map here:
    http://fuchsteufel.com/en/#location-opening-hours

    The error is definetily caused by the custom theme (I guess it’s a CSS setting). I tested it with Twentyseventeen and it worked. So, do you have another suggestion?

    Maybe this hint is helpful: If you pan the map to the west, the tiles are visible, but the first tile column next to the grey area is distorted.

    We would be glad if you could provide a possible solution here. Using the browser debug tools with Google Maps is quite complicated, as you certainly know, and it did not lead to any solution yet.

    Thanks!

    Kind regards
    winnewoerp

    • This reply was modified 2 years, 4 months ago by winnewoerp. Reason: wrong link
    • This reply was modified 2 years, 4 months ago by winnewoerp.
    #32164

    Hi winnewoerp.

    Thanks for getting in touch and sorry for the trouble.

    Can I please ask if you have tested this custom CSS as mentioned previously in this thread:
    #wpgmza_map img {
    max-width: 255.5px !important;
    width: 255.5px !important;
    max-height: 255.5px !important;
    height: 255.5px !important;
    }

    The issue is being caused by CSS that is overriding the maps CSS.

    Please let me know if this helps.

    Kind regards,
    Dylan

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.