Google Maps Map Engine Not Working, Open Maps Working

New home Forums Basic Version Troubleshooting Google Maps Map Engine Not Working, Open Maps Working

This topic contains 63 replies, has 3 voices, and was last updated by  cwilliams 2 months, 2 weeks ago.

Viewing 15 posts - 46 through 60 (of 64 total)
  • Author
    Posts
  • #50677

    Perry
    Moderator

    Hi there

    Firstly, please accept my apologies for the misunderstanding and resulting back and forth on this, I can see the same thing at our end now.

    Could you perhaps disable caching to work on and test this custom code?

    I’ve made adjustments and can confirm that when I accept location sharing, I see my location at zoom level 13.

    If I launch a private window and deny location sharing, then I see the USA at zoom level 3.

    Can you please confirm you are seeing the same result?

    Kind regards
    – Perry

    #50686

    cwilliams
    Member
    This reply has been marked as private.
    #50704

    Perry
    Moderator

    Hi there

    We have added more custom JS to achieve that for you.

    Can you please confirm that’s working as expected at your end?

    Kind regards
    – Perry

    #50761

    cwilliams
    Member
    This reply has been marked as private.
    #51391

    cwilliams
    Member

    Hey Perry,

    Checking back on my questions.

    Thanks

    #51460

    Perry
    Moderator

    Hi there,

    I’m so sorry for the delay in responding, I didn’t receive any notification in our support desk that you had posted. I’ve subscribed to the thread so this won’t happen again.

    The js to click off the infowindow to close is working perfectly. The js to move the user location pin to the top isn’t.

    This is working perfectly at our end, can you please check that you haven’t blocked location sharing on the device you are on?

    What would be required to provide a list view of the pins based on distance from the user? On my old build, I had Map View and List View so users could switch to List View to see a simple list that just had Name, Adddress, and Distance.

    This is not supported in our current release at all. Our upcoming major release, Pro 8, does support this. If you purchased within the last 6 months we can offer you a courtesy upgrade when Pro 8 goes to release.

    Another question is what would be required to allow the user to search for a location?

    If you mean suggesting locations that already exist, this is a surprisingly complex problem. We can potentially adapt the plugin for you to do this, however this would be subject to a customisation quote. Please note that at present, we have a waiting list of at least 6 – 8 weeks for custom work.

    Kind regards
    – Perry

    #51491

    cwilliams
    Member

    I’m definitely not blocking location sharing as that has worked from the get-go. Here is a screenshot of location pins showing up on top of my location pin. https://jmp.sh/Au7ajpT

    A brand new issue as you may have seen from the prior link is my location pin is now showing as the exact same pin as all the others. https://jmp.sh/voe0yAU

    And my question about the user being able to search would be the same functionality as we can do on the backend end. Just a standard search of the pins in the database. So the user is on the site and is looking for a specific patio so they just search for it. Since I’m allowing user submissions this will also allow people to search to see if a location is already listed.

    I purchased April 14 so I would be eligible for Pro 8 which has the list view. When is that due out? Will it allow the user to view the list by A-Z, Z-A or Near-Far, Far-Near? My most obvious use-case would be the user wants to see which patios are closest in any direction and also not have to click on each pin to see the name of each restaurant.

    Thanks, Perry

    #51492

    Perry
    Moderator

    Hi there

    Have you cleared your cache and is the Pro add-on up to date?

    We were unable to reproduce this issue at our end, the user location marker setting is respected.

    We’re also unable to reproduce the issue with custom JS panning to the user location.

    This sounds very much like browser caching kicking in. Could you please clear your cache, do a hard refresh, or use developer tools to temporarily disable the cache?

    You can use the “Advanced table” marker listing to mirror the back end functionality on the front end. You can use the store locators “Title search” to do this without a marker listing.

    The list can already be sorted alphabetically, sort by distance is part of the Pro 8 feature set.

    I hope that helps?

    Kind regards
    – Perry

    #51505

    cwilliams
    Member

    Cloudflare Cache was cleared as was the Browser Cache. Did a Hard Refresh, tried Incognito Mode and Firefox and IE. Also disabled in Dev Tools. All are doing the same thing. https://jmp.sh/ZaejlGP

    When I toggle on Advanced Table the map just goes white https://jmp.sh/gkoIrSs

    Also, now with the newest updates, the code we’ve added for the filter doesn’t work. I haven’t touched it. https://jmp.sh/1ZoY5En

    #51521

    Perry
    Moderator

    Hi there

    We’ve re-uploaded the user location icon, that will no longer use the map default.

    Regarding the Advanced Table issue, we’ve identified this as a bug. This happens when the dataTables library that this feature uses is passed a table with no columns. We’ll be patching this, however in the mean time, you will need to go to Maps -> Settings -> Marker Listing and allow at least one column to be shown. At the moment, you have all columns disabled / hidden, which causes this issue.

    Regarding the filtering issue, we solved this issue in our 7.11.39 release. We noted your site was using 7.11.38 – so we applied today’s 7.11.40 update to your site.

    The JavaScript we’re seeing from /wp-google-maps-pro/js/v8/marker-listings/marker-listing.js does not match what we have locally, so it would appear this file is being cached. We’re also seeing minified code being produced from this file, indicating that something is optimizing this and preventing the update changes from being reflected. Can you again please clear any and all caches and CDN’s the site is using?

    Kind regards
    – Perry

    #51634

    cwilliams
    Member

    The map marker is now working again, but it’s still not showing above the other pins.

    I did what you said and turned on a few of the columns, but as you can see the way it’s designed isn’t useful because it covers the entire map. Is there a way for it to be below the map or could be toggled so it either shows the list view or the map view?

    https://jmp.sh/HulyJMV

    #51651

    Perry
    Moderator

    Hi there

    Are you using the “Push in map” marker listing setting?

    If so, can you please to go your marker listing options and add some size restrictions for the table, for example 30% width and 30% height. This will prevent the table from obscuring the entire map.

    Regarding the markers and layer order, you can force the user location marker to be above all other markers using

    jQuery(function($) {

    $(document.body).on(“userlocationmarkerplaced.wpgmza”, function(event) {

    event.target.userLocationMarker.setOptions({zIndex: 999999});

    });

    });

    Unfortunately, it is not possible to place this above cluster icons:

    https://stackoverflow.com/questions/10243855/google-maps-render-marker-above-markerclusterer

    There is one answer with a proposed solution there, but considering that’s not officially documented, and Google provide no mechanism to do this with their library, we cannot condone this approach as it could potentially break at any time.

    I hope that helps?

    Kind regards
    – Perry

    #51673

    cwilliams
    Member

    I don’t see the “Push in map” market listing setting.

    However, when I turned on Advanced Table and set the container width and container height to 30% this is what I get https://jmp.sh/3LRDNNw.

    This question wasn’t answered. Is there a way for it to be below the map or could be toggled so it either shows the list view or the map view? Having the list on top of the map just isn’t user-friendly. If it could be toggled open when the user wants it and then toggled off when they don’t then that would be useable.

    Also, I”m not getting notifications any longer when you reply even though I’ve always had the “notify me of follow-up replies via email” turned on. I’ve tried unchecking and rechecking as well.

    #51713

    cwilliams
    Member

    Following up on this.

    #51728

    Perry
    Moderator

    Hi there

    Begging your pardon for the delay in responding – for some reason this ticket didn’t re-open following your response.

    We set your marker listing to “Advanced Table” style and then unchecked “Move list inside map”.

    The list is now below the map on your home page.

    We can help you with JavaScript to hide and unhide the listing, we would ask that you add the toggle so you can get that exactly how you would like, then we’ll provide the code to implement the logic for your control.

    Also, I”m not getting notifications any longer when you reply even though I’ve always had the “notify me of follow-up replies via email” turned on. I’ve tried unchecking and rechecking as well.

    We are actively looking into issues with this however the notifications are working at our end – can you please check your spam folder.

    Does that help?

    Kind regards
    – Perry

Viewing 15 posts - 46 through 60 (of 64 total)

You must be logged in to reply to this topic.