Google Maps Map Engine Not Working, Open Maps Working

New home Forums Basic Version Troubleshooting Google Maps Map Engine Not Working, Open Maps Working

This topic contains 63 replies, has 3 voices, and was last updated by  cwilliams 2 months, 2 weeks ago.

Viewing 15 posts - 31 through 45 (of 64 total)
  • Author
    Posts
  • #50031

    SupportTeam
    Moderator

    Hi there,

    The form is most likely not showing because you aren’t logged in and have the “Who can add markers?” option in the map editor under the VGM tab set to Registered users. This will hide the form to non-logged in users.

    Ok, I’m going to get our lead developer to check out that last issue and look at the videos you made about the pins/infowindows. He can also then respond about the custom work as well.

    Thanks so much,

    Kind Regards,
    Trevor Anderson

    #50043

    Perry
    Moderator

    Hello there,

    My name is Perry, I’m the Lead Developer on this project, pleased to meet you.

    Regarding what you are seeing there with the marker positioning, please note that the Marker Separation module offsets marker positions by pixels. That means that the marker will move independently of the current zoom level.

    The reason for this design is so that if you have several markers that share the same address, they will separate consistently at any zoom level, so that it’s not required for the user to pick the correct zoom level to see the separation groups opening.

    Please try our demo, if you open the group up and then zoom in and out, you will see clearly what is going on here.

    You could try not using the separation algorithm, and set a very high max zoom level for your clusterer. This will display a cluster icon for neighbouring addresses until the user gets to a very high zoom level, at which point they should be clearly separate.

    Does that help?

    You didn’t state which time zone you are in, we have staff in the CT and GMT timezones, I would be more than happy to assist if you would prefer to be transferred. Please just let us know.

    Kind regards
    – Perry

    #50058

    cwilliams
    Member
    This reply has been marked as private.
    #50082

    Perry
    Moderator
    This reply has been marked as private.
    #50119

    cwilliams
    Member
    This reply has been marked as private.
    #50124

    cwilliams
    Member
    This reply has been marked as private.
    #50196

    SupportTeam
    Moderator

    Hi there,

    A new version of Visitor Generated Markers will be released soon and should resolve some of these issues.

    As for the email saying Me, this is likely because the email program you are using (I’m guessing you’re checking this in gmail) sets it as such, we do set the from as the blogname and then the email address set to deliver to.

    For the Florida issue, is this the default viewpoint of the map in the map editor? When finding the user location it may take several moments for it to return this, this is how Google’s API works, so as soon as it returns the location it pans/moves to it.

    Thanks so much,

    Kind regards,
    Trevor Anderson

    #50420

    cwilliams
    Member
    This reply has been marked as private.
    #50440

    Perry
    Moderator

    Hi there

    The map will start at the last location you left it in when you saved the map, which happens to be Florida in this case, at the zoom level you last set it to.

    I visited your map edit page, zoomed out and placed the viewport to cover the USA, then clicked Save Map. I can confirm if you visit the front end and decline location sharing, the viewport shows the USA as expected.

    We’re hopeful to get VGM 3.13 out later today pending a couple of other fixes we need to add in before release, please accept our apologies for the delay in getting this out. If you need a pre-release, we can provide that.

    Kind regards
    – Perry

    #50464

    cwilliams
    Member
    This reply has been marked as private.
    #50523

    Perry
    Moderator

    Hi there

    Please drag and zoom the map in the map editor to set the default center and zoom level.

    If you have done so and this is appearing off center, can you please confirm you have “Automatically pan to users location” switched off in Maps -> Edit -> Advanced Settings?

    Kind regards
    – Perry

    #50534

    cwilliams
    Member
    This reply has been marked as private.
    #50575

    cwilliams
    Member
    This reply has been marked as private.
    #50624

    Perry
    Moderator

    Hi there

    I see, thank you. My apologies for the delay in responding.

    If you are still experiencing the issue with the map zooming in and centering on an irrelevant location (Florida as you reported) please can you clear your cache or do a hard refresh.

    We tried visiting your page and blocking geolocation, the map remained focused on the USA as it is shown on the map edit page.

    We have added additional custom JS to Maps -> Settings -> Advanced which sets the zoom level to 13 when the map initialises.

    Is that the result you were looking for?

    Kind regards
    – Perry

    #50638

    cwilliams
    Member
    This reply has been marked as private.
Viewing 15 posts - 31 through 45 (of 64 total)

You must be logged in to reply to this topic.