Geocode was not successful for the following reason: fail

New home Forums Basic Version Troubleshooting Geocode was not successful for the following reason: fail

This topic contains 3 replies, has 3 voices, and was last updated by  gleung 2 months, 4 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #50591

    Hello! I’ve enabled all the necessary API’s, but it still says “Geocode was not successful for the following reason: fail”.

    I disabled and re-enabled the Geocode API, but nothing changed.

    What else can I do?

    Thanks very much

    #50592

    Hello again,

    I just realized that when I created the API yesterday, I create restrictions for the Google Maps API (since that’s what Google Console suggested).

    Now that I’ve removed the restrictions, the map plugin works fine.

    My only question is, Google is still saying I should restrict the APIs to prevent unauthorized use and quota theft. So what should I do about that?

    Thanks again all.

    #50615

    AbelC
    Moderator

    Hi There,

    Thank you so much for getting in touch with us, and our sincere apologies for the inconvenience.

    You will want to restrict access to your API Key to prevent unauthorized use and also quota theft.

    Could I kindly ask if you could please follow the steps below:
    1. Please navigate to the Google API Manager https://console.developers.google.com/apis/api/
    2. The referrers are set in the Credentials. Could I kindly ask if you could please click Credentials in the left-hand column in the Dashboard.
    3. Could you please then click the Pencil icon to the right of the API key to select your Google Maps project
    4. Application restrictions -> select HTTP referrers (web sites)
    5. Add the following referrers to the text boxes below Website restrictions:
    *.example.com/*
    *example.com/*
    Please replace example.com with your domain name:

    More information can be found here: https://www.wpgmaps.com/documentation/ensuring-your-referrers-are-properly-inserted/

    I hope this helps clarify?

    Please do let me know if this is working for you, and I look forward to hearing back from you.

    Kind Regards,
    Abel

    #51393

    gleung
    Member

    I’m trying to create my first marker in WP Google Maps Pro and I’m getting the same error message and this error message “Geocoding Service: This API key is not authorized to use this service or API. For more information on authentication and Google Maps JavaScript API services please see: https://developers.google.com/maps/documentation/javascript/get-api-key

    I’ve gone through the steps to set up the referrers as per your instructions above, but still having no luck. What steps am I missing?

    Attachments:
    You must be logged in to view attached files.
    #51406

    AbelC
    Moderator

    Hi There,

    Thank you so much for getting back to me, and our sincere apologies for the inconvenience.

    Yes, you will want to restrict access to your API Key to avoid having it “hijacked” and going over your quota.

    Would it perhaps be possible to please follow these steps below to add restrictions to your API:
    1. Please navigate to the Google API Manager https://console.developers.google.com/apis/api/
    2. The referrers are set in the Credentials. Could I kindly ask if you could please click Credentials in the left-hand column in the Dashboard.
    3. Could you please then click the Pencil icon to the right of the API key to select your Google Maps project
    4. Application restrictions -> select HTTP referrers (web sites)
    5. Add the following referrers to the text boxes below Website restrictions:
    *.example.com/*
    *example.com/*
    Please replace example.com with your domain name:

    Could I also kindly ask if you could please confirm if you have enabled the following API Keys:
    – Google Maps JavaScript API
    – Google Maps Geocoding API
    – Google Places API
    – Google Maps Directions API
    – Google Maps Distance Matrix API
    – Google Street View Image API

    If this issue still persists, could I kindly ask if you could please provide us with a link to your Map page so that we can take a closer look as to what is causing this issue?

    Would it also perhaps be possible to please confirm your WP Google Maps Basic + Pro versions installed on your site?

    This will be a tremendous help.

    We look forward to hearing back from you and getting this issue resolved as soon as possible.

    Kind Regards,
    Abel

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.