Geocode failed due to technical reasons

New home Forums Gold Add-on Geocode failed due to technical reasons

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #69496
    dslatten
    Participant

    I am trying to customize my markers but cannot save as I keep getting a “Geocode failed due to technical reasons” error. I have the following APIs added and anabled:
    Directions API
    Distance Matrix API
    Geocoding API
    Geolocation API
    Maps Embed API
    Maps JavaScript API
    Maps SDK for iOS
    Places API
    Street View Static API

    #69497
    dslatten
    Participant

    Nevermind, I believe I figured it out.

    #69528
    Matthew
    Moderator

    Hi there,

    Thank you for getting in touch with us, we do appreciate your time.

    I am glad to hear that you have figured it out and should you require any further assistance, please do not hesitate to ask as we are more than happy to help.

    Kindest Regards,
    Matthew

    #69560
    Mister3
    Participant

    Noooooooo!!!!!

    Don’t just say “nevermind”. What did you figure out?

    I’m having the exact same problem. Any clue would be helpful.

    Actually I’ve now figured out that I needed to enable the “Geocoding API”.

    After I enabled the “Geocoding API”, the “Geocode failed due to technical reasons” error went away, but I still had problems.

    I ended up having to save the map and delete out the duplicate markers that I had created for every time I caused a “Geocode failed due to technical reasons” error

    #69564
    Matthew
    Moderator

    Hi there,

    Thank you for getting in touch with us, and my apologies for the inconvenience you are experiencing.

    I am more than happy to assist you with the issue on your site, thus please could I kindly ask you to confirm what issues you are still experiencing after the “Geocode failed due to technical reasons” error got resolved?

    I look forward to hearing back from you.

    Kindest Regards,
    Matthew

    #69835
    werkform
    Member

    Same problem here while updating existing Markers on older Maps.

    Solution was (thx Mister3!!) to enable the Geocoding API at the GoogleAPI-Key for this project. If you limit your key (recommanded!) 2 API’s mus be enabled (see screenshot).

    Attachments:
    You must be logged in to view attached files.
    #69861
    Matthew
    Moderator

    Hi there,

    Thank you so much for the confirmation and affirmation to resolving this issue, we really appreciate it!

    Should you require any further assistance, we are more than happy to help!

    Kindest Regards,
    Matthew

    #72112
    nikkip
    Participant

    Hello, I have the same problem – but can’t see the screenshot above.
    APIs enabled and credentials seem ok
    I’m updating images on an old map
    thanks for your help

    #72127
    Matthew
    Moderator

    Hi nikkip,

    Thank you for reaching out to us, we do appreciate your time.

    The issues that previous users experienced was caused by some API not being activated as well as some API’s not being authorized to be used by your API key. Please see the below for each scenario:
    ApiNotActivatedMapError
    1. Go to the Google Cloud Platform Console – https://console.cloud.google.com/
    2. Click the Library link in the “APIs & Services” sidebar menu.
    3. Click on the Places API panel to open it.
    4. Click “Enable” in the Places API window.

    Please also ensure that the following APIs are enabled as these are required for WP Google Maps to functions correctly:
    – Google Maps JavaScript API
    – Google Maps Geocoding API
    – Google Places API
    – Google Maps Directions API

    Once this has been done, please could I kindly ask you to confirm if the issue has been resolved?

    Documentation for this process can be found under the “Enabling required API Functions” section: https://www.wpgmaps.com/documentation/creating-a-google-maps-api-key/

    ApiNotAuthorizedMapError
    1. First, log in to the Google API Manager – https://console.developers.google.com/apis/api/
    2. Click on the ‘Credentials’ tab in the left-hand column.
    3. Click the “Pencil icon” on the right side of the API key for your Google Maps project.
    4. Under the “API restrictions” section, please ensure that it is set to the “Don’t restrict key” option, or ensure that all the respective APIs are enabled in the “Restrict key” dropdown menu.
    5. Click the “Save” button.

    Please ensure that the following APIs are enabled as these are required for WP Google Maps to functions correctly:
    – Google Maps JavaScript API
    – Google Maps Geocoding API
    – Google Places API
    – Google Maps Directions API

    Once this has been done, please could I kindly ask you to confirm if the issue has been resolved?

    Please do let me know if this helps?

    I look forward to hearing back from you.

    Kindest Regards,
    Matthew

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.