Filtering markers by category causes InfoWindow image size problem

New home Forums Pro Add-on Troubleshooting Filtering markers by category causes InfoWindow image size problem

Tagged: ,

  • This topic has 5 replies, 3 voices, and was last updated 3 years ago by Perry.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #29183
    Jim
    Member

    I’m using WP Google Maps Pro V6 on my website. It works well, for the most part, but there’s one problem which I’m hoping you can fix.

    My png images in the Basic table marker list are 212 x 140 px. I’ve set these to display much smaller (78 x 52 px) in the InfoWindows. This works just fine unless I filter the markers by category. Then the images appear at full size in the InfoWindows, which crowds out the text and causes the InfoWindows to become so tall they cover most of the map when viewed on mobile devices.

    Filtering the markers shouldn’t change the way the images display in the InfoWindows. What’s the fix?

    Thanks,

    Jim

    #29187
    SupportTeam
    Moderator

    Hi Jim,

    Thank you for getting in touch with us and I apologize for any inconveniences you have encountered.

    Can you please send me a link to your site so that I can take a look at the map as it is possible that your theme is overriding the plugin styles or your Images are still containing size parameters ie – image.png/212px ..etc

    Can you also please tell me what versions of our plugins you are using on your site at the moment?

    Thank you for your time in this matter.

    #29190
    Jim
    Member
    This reply has been marked as private.
    #29195
    Perry
    Moderator

    Hi Jim, Hi Nathan,

    Thank you for bringing this to my attention, this is indeed a bug. I’ve filed an issue in our repo and we’ll have this corrected in future releases

    In the mean time, you can go to Maps -> Settings -> Advanced -> Custom CSS and use the following CSS the force your images to 90px wide:

    .wpgmza_infowindow_image
    {
    width: 90px !important;
    height: auto !important;
    }

    Please let me know if that works for you?

    Kind regards

    #29196
    Jim
    Member

    That does the trick. Thanks!

    #29203
    Perry
    Moderator
    This reply has been marked as private.
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.