Feature request: Apple Style list

New home Forums Gold Add-on General queries Feature request: Apple Style list

This topic contains 15 replies, has 2 voices, and was last updated by  Dylan 2 years, 5 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #23645

    phil
    Member

    Hi there,

    is there a way to display the map right next to the listing?

    Above just a search file to input zip code or sth.
    Like a 2 column display: left = list / right = map

    Like Apple does:

    https://locate.apple.com/de/de/sales/?pt=all&lat=51.2137374&lon=6.7614814&address=40219

    Thanks,
    Phil

    • This topic was modified 2 years, 8 months ago by  phil.
    #23656

    Dylan
    Moderator

    Hi Phil,

    Thank you so much for getting in touch with us.

    Yes this can be achieved by altering the layout settings slightly, in conjunction with adding some custom CSS.

    1. Please open the map within the map editor -> Click on Marker Listing Options -> Select your listing of choice and set the option labelled ‘Marker Listing Placement’ to ‘Above Map’.
    2. Next, click on the General Settings tab -> And adjust the map width to 50%.
    3. Click on the Advanced Settings tab -> And adjust the option labelled ‘Map Alignment’ to ‘Right’.
    4. Save your map.
    5. Finally, Click on Maps -> Settings -> Advanced -> And add the following CSS to the Custom CSS box:

    .wpgmza_marker_list_class {
        display: inline-block;
    }
    

    6. Save the global settings.

    I hope this helps?

    #23657

    phil
    Member

    thanks for your reply dylan!
    everything fine so far but i dont have the option ‘Marker Listing Placement’ i do have the latest version. thoughts?
    thanks
    phil

    #23658

    phil
    Member

    …here you can see my options

    Attachments:
    You must be logged in to view attached files.
    #23688

    Dylan
    Moderator

    Hi Phil,

    Thank you so much for your time.

    Could I ask you to confirm what version of the Pro add-on you have installed?

    As this will only be available from version 6 and above.

    Thank you so much for your time. 🙂

    #23716

    phil
    Member
    This reply has been marked as private.
    #23720

    phil
    Member

    ..ok i solved it…still there are some issues when clicking on a list item an displaying it correctly (ull see in the private message if you try)

    another thing: is there a way to get rid of the “show xx entries” string?
    I only want to sho a bigh search input field centered above the list.
    Thank you!
    Philipp

    #23738

    Dylan
    Moderator

    I Philipp,

    So glad to hear you got this working on your side.

    I did test clicking on a marker listing, but I was unable to find any issues with this.

    Please try adding the following CSS to hide the Show XX Entries String:

    .dataTables_length {
        display: none;
    }
    

    I hope this helps? 🙂

    #26011

    phil
    Member

    thanks! I now want to change the input field (search) styling. i want it to be bigger (50px) what do i have to edit? thanks! phil

    #26015

    Dylan
    Moderator

    Hi again,

    This can be achieved by simply adding the following:

    
    .addressInput {
    height: 50px !important;
    }
    

    I hope this helps?

    #26016

    phil
    Member
    This reply has been marked as private.
    #26074

    Dylan
    Moderator

    Hi Phil,

    So sorry for the misunderstanding.

    I was under the impression that you were trying to change the store locators input field, my mistake.

    To adjust the DataTables search field, simply add this CSS instead:

    .dataTables_filter input[type=search] {
        height: 50px !important;
    }
    

    I hope this helps? 🙂

    #26206

    phil
    Member

    Hi Dylan,

    I’m sorry – no it’s not working. No change whatsoever – any other thoughts?
    Thanks,
    Phil

    #26232

    Dylan
    Moderator

    Hi Phil,

    It appears that the changes have now taken affect?

    However the height is set to 100px instead of 50px. Please remember to clear your cache when making such changes.

    I hope this helps? 🙂

    #26241

    phil
    Member

    you are right – thank you! Just Safari ist nor rendering it right…all other browsers work…

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.