Error message following search

New home Forums Pro Add-on Error message following search

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #59920
    timmy321
    Participant

    Hi,

    I’ve just purchased the pro add on, altered the maps from openstreet to google and put my api key in.

    Unfortunately an error message occurs when searching now (easiest way to say it is to attach the screenshots). I’ve checked my api google account (image 3) and confirmed i have the maps api so I’m confused as to what’s happening as everything seemed to work nicely before i purchased the pro add on.

    I should mention Perry very kindly provided me with some JS to redirect the search facility on my homepage to a separate page containing the map. I don’t know whether this could be causing issues now I’ve got the pro add on?

    Any help would be greatly appreciated,

    Many thanks,

    Tim

    Attachments:
    You must be logged in to view attached files.
    #59928

    Hi Tim,

    Thanks so much for getting in touch and apologies for the inconvenience.

    It seems like this is due to one of the required libraries not being enabled for the API key.

    To fix this, could I kindly ask you to log into your Google Cloud Console and navigate to API’s and Services and under the ‘Libraries’ option please ensure the following API’s are enabled:
    – Maps JavaScript API
    – Maps Geocoding API
    – Maps Geolocation API
    – Maps Places API
    – Maps Directions API

    Once these are enabled and activated, could I kindly ask you to have another look and let me know if this works as expected?

    Thanks for your time.

    Best regards,
    Dylan

    #59939
    timmy321
    Participant

    Worked an absolute treat Dylan,

    Big thanks,

    Tim

    #59955

    Hi Tim,

    That is great to hear and is only a pleasure.

    Thanks again for your time and please do let me know if there is anything else I can assist you with.

    Best regards,
    Dylan

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.