Category filter icons display as insecure http, rest of site is https

New home Forums Basic Version Troubleshooting Category filter icons display as insecure http, rest of site is https

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #56085
    JenF
    Member

    Our map page will not display over HTTPS because the page has mixed, insecure content. It looks like the insecure content is the category icons in the filter section. The image sources are http, not https.

    If I deselect “Allow users to filter by category?”, then the page displays securely, but with the filter enabled, it does not.

    Our Projects

    I have confirmed that in the media library the category icons show a permalink with https. I’ve also checked the Map Categories section and made sure that the URL for each category marker starts with https.

    Can you please let me know what I can do to force the filter’s category icons to display via https?

    Thanks!
    Jennifer

    #56099
    Dylan
    Moderator

    Hi Jennifer,

    Thank you for getting in touch, we do appreciate your time.

    I had a look at your map page and I can confirm that all icons loaded by our plugin are currently being loaded via ‘https’ and should not cause any mixed content notices.

    With that said, I looked into this a bit further and I believe I may have found the cause of the issue.

    I found the following custom JavaScript present on your website:

    $(window).bind("load", function() {
    $("#wpgmza_cat_checkbox_0").after("<img src='http://solasenergyconsulting.com/wp/wp-content/uploads/2016/06/1x1.png' style='height:32px;width:1px;' />");
          $("#wpgmza_cat_checkbox_1").after("<img src='http://solasenergyconsulting.com/wp/wp-content/uploads/2016/05/biomass-1.png' alt='Biomass' />");
       $("#wpgmza_cat_checkbox_2").after("<img src='http://solasenergyconsulting.com/wp/wp-content/uploads/2016/05/caes.png' alt='CAES' style='padding: 0 4px 0 2px;' />");
       $("#wpgmza_cat_checkbox_3").after("<img src='http://solasenergyconsulting.com/wp/wp-content/uploads/2016/05/cogen2.png' alt='Cogeneration' style='padding: 0 3px 0 2px;' />");
       $("#wpgmza_cat_checkbox_4").after("<img src='http://solasenergyconsulting.com/wp/wp-content/uploads/2016/06/1464927812_database.png' alt='Fuel Cell' style='padding:6px 4px 2px;' />");
       $("#wpgmza_cat_checkbox_5").after("<img src='http://solasenergyconsulting.com/wp/wp-content/uploads/2016/05/geothermal-1.png' alt='Geothermal' />");
       $("#wpgmza_cat_checkbox_6").after("<img src='http://solasenergyconsulting.com/wp/wp-content/uploads/2016/05/wind.png' alt='Offshore Wind' />");
       $("#wpgmza_cat_checkbox_7").after("<img src='http://solasenergyconsulting.com/wp/wp-content/uploads/2016/05/hydro-1.png' alt='Hydro' />");
       $("#wpgmza_cat_checkbox_8").after("<img src='http://solasenergyconsulting.com/wp/wp-content/uploads/2016/05/solar.png' alt='Solar' />");
       $("#wpgmza_cat_checkbox_9").after("<img src='http://solasenergyconsulting.com/wp/wp-content/uploads/2016/05/transmission-1.png' alt='Transmission' style='padding: 0 2px 0 2px;' />");
       $("#wpgmza_cat_checkbox_10").after("<img src='http://solasenergyconsulting.com/wp/wp-content/uploads/2016/05/wind.png' alt='Wind' />");

    As seen above, this makes use of the ‘http’ protocol instead of the required ‘https’ alternative.

    Could I ask you to check Maps -> Settings -> Advanced -> within the custom JavaScript box to determine if this code was added to our scripts container?

    If so, simply replacing each instance of ‘http’ with ‘https’ instead, should resolve the issue.

    I hope this helps?

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.