Activating pro causes map to not show

New home Forums Pro Add-on Installing and Updating Activating pro causes map to not show

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #59899
    toremackay
    Participant

    Hi!

    I just updated to basic version 8.0.25 and Pro version 8.0.29.

    When I activate the pro version my maps are replace by a form with title “Get directions”. When I deactivate it again maps reappear.

    Any idea what the issue is and how I can fix it?

    #59900
    Perry
    Moderator

    Hi there

    Thank you for getting in touch, sorry to hear you are experiencing issues.

    Please can you link us to your map page so that we can observe this?

    Kind regards
    – Perry

    #59904
    toremackay
    Participant

    Here is a link to a page that should show map:

    Sone 3

    If I deactivate Pro the map will show.

    • This reply was modified 1 month, 1 week ago by toremackay.
    #59906
    toremackay
    Participant

    FYI

    I get this error in the console:

    wp-google-maps-pro.m…8.0.25+pro-8.0.31:1 Uncaught ReferenceError: google is not defined
    at HTMLDocument.<anonymous> (wp-google-maps-pro.m…8.0.25+pro-8.0.31:1)
    at i (jquery.js?ver=1.12.4-wp:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4-wp:2)
    at Function.ready (jquery.js?ver=1.12.4-wp:2)
    at HTMLDocument.J (jquery.js?ver=1.12.4-wp:2)
    (anonymous) @ wp-google-maps-pro.m…8.0.25+pro-8.0.31:1
    i @ jquery.js?ver=1.12.4-wp:2
    fireWith @ jquery.js?ver=1.12.4-wp:2
    ready @ jquery.js?ver=1.12.4-wp:2
    J @ jquery.js?ver=1.12.4-wp:2

    #59909
    toremackay
    Participant

    Any one have an idea of why it is not working when activating pro?

    #59911
    Perry
    Moderator

    Hi there

    The issue in this instance is that there appears to be 3rd party software changing the Google API script tag to “noscript”.

    This effectively prevents the Google API from loading.

    Are you able to disable all 3rd party plugins temporarily, then start to re-enable them one by one until we can establish the source of this behaviour?

    Kind regards
    – Perry

    #59915
    toremackay
    Participant

    I disabled all 3rd party plugins, including once demanded for theme for work, but error still remains. Any other ideas?

    Remember it works when running free version. It is when I activate Pro version it breaks.

    • This reply was modified 1 month, 1 week ago by toremackay.
    #59918
    Perry
    Moderator

    Hi there

    There are no code points in our plugin or the Pro add-on that change a script tag to noscript, there must be 3rd party software somewhere on the site making this change.

    I’m unsure why you’re seeing this when enabling Pro, there must be something in our Pro code that triggers different handling of the script tag by whichever code is changing that to a noscript tag.

    Did you also try switching back to the default theme?

    Would you be open to sharing access to this site with us via a support ticket at https://www.wpgmaps.com/contact-us/ ?

    Kind regards
    – Perry

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.