9,000+ Map Data Causes Server Timeout Error 500

New home Forums Pro Add-on Troubleshooting 9,000+ Map Data Causes Server Timeout Error 500

Tagged: , ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #34636
    tim.dempsey
    Member

    I have started to change the max_timeout in the .user.ini on an Azure hosted WordPress install.
    It seems to import a fair amount, but not all.

    How can I configure a store locator of that size to reliably import all locations?

    Thanks,

    • This topic was modified 3 years, 7 months ago by tim.dempsey.
    • This topic was modified 3 years, 7 months ago by tim.dempsey.
    #34649
    Perry
    Moderator

    Hi Tim,

    Thanks for getting in touch, sorry to hear you’re having issues here!

    Your files must be pretty gigantic as they’re too big for the forum, can you please upload them to Google Drive or similar and send me the download links in a private message?

    In theory as long as your timeout setting is respected in PHP then the import should run well,

    If you have any problems then please let me know, we have a more robust importer I can run the files through, this should be integrated into the plugin in the near future to mitigate issues like yours.

    Please let me know on that and we’ll get this resolved for you as soon as possible!

    Kind regards
    – Perry

    #34656
    tim.dempsey
    Member
    This reply has been marked as private.
    #34692
    tim.dempsey
    Member

    bump

    #34700
    Perry
    Moderator

    Hi Tim

    My apologies for the delay in responding, I’m in the GMT timezone here and have only just seen your reply,

    The first 3534 rows of this CSV will import to map ID 1 just fine, after that (rows 3536 and onwards) you have no map_id set for the markers and approved is blank, which means they will be on map ID 0 and unapproved, so these markers wouldn’t be displayed. If this wasn’t your intention, you’ll find if you fill out those columns that the markers will appear.

    Regarding the performance issues, all I can suggest is either getting your hosting package upgraded to one with better performance or breaking the CSV up into smaller batches. I assume you’re not using the “Geocode” option?

    Please try that and let me know if that solves the problem for you?

    Kind regards
    – Perry

    • This reply was modified 3 years, 7 months ago by Perry.
    #34750
    tim.dempsey
    Member

    Thanks Perry, a combination of splitting the file and changing the server timeout helps.
    Appreciate your response & guidance very much.

    FYI We are using Microsoft Azure

    • This reply was modified 3 years, 7 months ago by tim.dempsey.
    #34760
    Perry
    Moderator

    Hi Tim

    Thanks for letting us know!

    Is there anything else I can help you with?

    Kind regards
    – Perry

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.