3 Issues – can't track route (only markers), retry error, time stamp on markers.

New home Forums Gold Add-on Real time location tracking 3 Issues – can't track route (only markers), retry error, time stamp on markers.

This topic contains 3 replies, has 2 voices, and was last updated by  Dylan 2 years, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #24575

    interestica
    Member

    The plugin and Android app seem to work mostly as expected.

    On the backend, when I choose to create a ‘route’ as opposed to ‘Last Location Markers’ it still only adds markers sent in from the Android app.

    The timestamp on those markers are incorrect (or are displaying GMT0 time) – how can I get them to display based on the WP install or the Phone time?

    The app will sometimes, after saying ‘successfully sent’ go into a repeated ‘error – retrying’. The problem is that there is no error – and each retry gets stored as an additional marker. So I can have 10 markers for the same second.

    #24612

    Dylan
    Moderator

    Hi there,

    Thank you so much for getting in touch with us, please find my responses below:
    1. When switching to ‘route’ mode, the map editor will only display markers on the map. However if you navigate to the front end of your site you should see all of these markers disappear and a route drawn instead. Please have a look and confirm?
    2. Unfortunately the system makes use of the Server time at the moment. This would be relatively simple to change within the code if you are open to this?
    3. Could I ask if you are tapping the location button after the marker is successfully sent? This could be the cause as the app will send your location whenever the map location is requested.

    I look forward to resolving these issues for you. 🙂

    #24716

    interestica
    Member

    1. Front end definitely still just had multiple instances of the marker.

    2. Definitely want the code change – editing Gold plugin I presume?

    3. Not sure why it’s getting the error. It receives confirmation (“Location successfully sent”) and the marker appears on the backend. But, it thinks there’s an error and keeps retrying.

    Other than that, really like the plugin and its potential.

    #24734

    Dylan
    Moderator

    Hi there,

    Thank you so much for your feedback on this one.

    Could I ask you to send me a link to your map on the front-end if possible?

    Based on the information provided, I believe it is possible that the script which handles the route drawing may not be working as intended.

    This would be a great help.

    With regards to the server time. This can be altered by opening the wp-google-maps-gold.php file (plugins/wp-google-maps-gold/wp-google-maps-gold.php) and finding the following segment of code:

    $desc_text = sprintf( __( 'Location as at %1$s', 'wp-google-maps' ),
       date("Y-m-d H:i:s")
    );

    And changing it to the following instead:

    $desc_text = sprintf( __( 'Location as at %1$s', 'wp-google-maps' ),
       the_date("Y-m-d H:i:s")
    );

    I hope this helps?

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.